Download

How do I attach myself to my mannequin?

So just learning here and need a bit of basic help.

What I’ve done.

-Created a blank project
-Imported height map and made a bit of my environment
-From the content drawer, clicked +ADD, chose “Add Feature or Content Pack”, and added the “Thrid Person” Blueprint feature
-From the content drawer, I drug a “ThirdPersonCharacter” blueprint into my world.
-When I click ‘Play’ I end up as a spectator, I can see the mannequin, but I’m not controlling it.
-I changed the gamemodebase to thirdpersongamemode. No go
-In the project settings, under maps and modes, I changed the Default GameMode to ThirdPersonGameMode and I changed the DefaultPawn to ThirdPersonCharacter
Now when I click play, I end up controlling a ThridPerson mannequin that’s spawned in where ever my camera happened to be when I clicked play, but it’s not the mannequin I put into the world. I can walk around that other mannequin, but how do I make it to where that’s the one I’m controlling?

Thanks

I recommend a good brand of duct-tape…

Try looking at the sample 3rd person project for some of the basic settings, but it sounds like you’ve not touched your world-details panel and set your game-mode values? Also, is there a camera/boom-arm attached to your critter to see it through?

ref:
image

Thanks for the response.

I have actually two instances of UE open, one with my creation and a second with just the basic Third Person templet loaded. I’ve spent several hours trying to find differences in the settings with no luck. I’ve also watched just about every video on YouTube that seems even remotely connected to my problem.

Yes, I have the camera/boom-arm. All that stuff is set up in the blueprint which comes directly from the ThirdPerson templet and it all works fine in the instance that has just that templet.

And now that you’ve pointed me to the world settings, I’ve compared those settings in my project to those in the basic TP templet. The only one that is different is in the ‘world’ section called ‘Kill Z’. I haven’t figured out what Kill Z is yet, but I’m guessing it is related to ‘kill zone’ or the Z axis value that results in death for falling out of the world or whatever. I can’t find any info on it, but I doubt it has anything to do with my problem.

kill-z is the z-value in worldspace at wich the game kills you (presumably a large, negative number so it assumes you fell out of the world/level space and don’t keep falling forever…

Do you have a player-start in your world at all?

I tried putting a player start on the mannequin, but that didn’t work. It just spawned a new mannequin there on top of the one I had placed in the world. I then tried to put the PlayerStart under the ThirdPersonCharacter in the World Outliner, but that says something like, ‘Cannot attach static actor PlayerStart to dynamic actor ThirdPersonCharacter.’ I could do it the other way around, putting the TPC under the PS, but that still gave me the same problem. One controllable mannequin and one non-controllable one. When I overlapped the two, the controllable one can’t overlap with the non-controllable one, so you just fall out of the world.

Then I played around with a bunch of different things like deleting the TPC and adding a new one directly into the PlayerStart, the Collision Capsule under the PS, and so on. All that just lead to two overlapping collision capsules which lead to falling out of the world every time I hit play.

I’m sure there must be a way to do it, but apparently nobody knows how and there’s not much in the way of useful documentation for beginner folk like myself.

I gave up and restarted my work using the ThirdPerson templet, deleting everything but the starter mannequin, then I rebuilt my world and moved that mannequin to where I wanted it. Not an ideal solution, but it works for now.

Thanks for the suggestion though.

P.S. Thought I’d mention that there is no PlayerStart in the ThridPerson templet but you still start in the mannequin every time.

You have a Pawn in your world that you want to immediately possess instead of spawning the default pawn? Simplest thing in the world!

Click on your pawn that you want possessed, and search for “Auto Possess Player” in the Details panel. Set that to “Player 0” and it should work just fine.

Hope this helps!

That did it. Much appreciation!

You’re welcome!