Download

How do I add the library assets to my project?

I created a third person project, is there a way to use the content in UE4’s library and import it into my project?

I dont know which library you mean, but just open the project from that you want to have the assets (e.g shooter demo) - go into the content browser - right click onto the assets/folder that you want to migrate - choose migrate - select the path to the new project - ok

Now you should have those assets in your new project :slight_smile:

Thanks for the answer, I have not tried it out yet because I have been trying to replace the blue mannequin using this tutorial:

https://www.youtube.com/watch?v=tyYTYF0G5Kk

It’s very easy to replace the blue character -> just create your own skeletal mesh + animations and then follow the tutorial. When you have questions about stuff that is shown in this video, just ask them in here :slight_smile:

Thanks for your help with importing assets through the library.

Unfortunately for the model tutorial, the model I have is stuck in it’s idle animation so I don’t see the running/jumping.

I am following the youtube link in the previous post

It’s hard to say what could be wrong, but check if you have a speed variable in your animation bp + if it is connected with the blendspace in your anim graph. For the jumping you have to check if you have set up the part with the IsInAir bool :slight_smile: When it is still not solved, it would help if you could post some screenshots :wink:

here is a link to the problem:

https://www.youtube.com/watch?v=wYZRE3AxeJ0&feature=youtu.be

:wink: I have to see how your anim graph, anim bp and character bp looks like, because it could be that you have forgot to add a variable, that you have made a mistake in the blendspace,…

I’m still new with this please let me know if you need more information:

Imgur

Ok, lets go through some solutions :slight_smile:

-make sure that you have added the right anim bp in your character bp under the component tab in the skeletal mesh properties.
-check your blendspace if you have added the right animations to the right speed values
-check if the right skeletal mesh is assigned to the anim bp
-go into your anim graph and check in the idle/run state if you have added the blendspace + the speed variable

idle.jpg

I saw that you are using the basic blueprint as in the video -> normally it should work when you just follow my tutorial :slight_smile:

I started from scratch and it worked great for me, I definitely had a mistake somewhere in the animation blueprint, thanks for solving my problems. Going to make a jump land and jumping air animation and it all works fine now.