Download

How do I add an item to be crafted to something

what i mean is like the smithy can craft certain saddles but the player can’t how can I make an item I created (copied a storage box) craft an item I made (copied pearls)

Ok, I’d like to craft gold pearl using the new storage box requiring 25wood … I have most of it done but don’t get how to make the craftable show up in the storage box (I have it not showing on the player)

I’d also like to not make it a learnable engram by the player but be part of the shop (storage box)

EDIT: still no luck all I want to do is create a gold pearl from a large storage box at a cost of 25 wood. The part I can’t figure out is how to make the box 1. Able to craft the pearl 2. Able to craft it without the player learning an engram for that craft

Are you trying to make it so the box can store items and also craft items? I suggest copying something like the smithy and changing the model.

Oooo— that sounds more like the compost ben. You put 25 wood in it, and without the player needing to do anything, it crafts a pearl (or fertilizer in the ben’s case). Am I on the right track with that?

Yes null that’s what I’m trying to do … I got someone to tell me it’s the default items but now can’t figure out how to attach inventorybp to the storage box structure … but I ran into a bigger issue now I can’t even place the (created) storage box on the map… basically my goal is this

50 wood = 1 black pearl
obsidian = 6 black pearls
I know I have to make blackpearlA and blackpearlb so each of those have a recipe… and then somehow make backpearls the master so I can then turn all blackpearls A, B, C, D into gold pearls

then make another box that is I can craft 25 wood with 1 gold pearl and 1 obsidian for 12 gold pearls

I just can’t get it to place I don’t know what the hell is going on :frowning: it shows the green outline I place it makes the sound but nothing gets placed

Update: well I got everything to work in the bench but still can’t create the bench (i’ve been just putting it in the map from the editor) I get the engram … create, I get the craft … craft the item it’s in my inv… but when I “use” the item it doesn’t do anything not even the green outline now.

Update: I still can’t figure it out I copied primalitem structure_anvilbench and I copied storagebox_anvilbench and when I set the item to “Structure to build” = storagebox_anvilbench_copy I click use and nothing happens does anyone know a solution to this? I’ve been working on in for far too long and can’t any help anywhere about why this is happening… I can create the item from the editor straight to the map and it’s there with everything it is supposed to have but just can’t create it using “use” from my inventory

Finally found the answer I was missing step 3 man talk about a pain :slight_smile: