How can I set the default resolution of a packaged game?

I’ve done some intensive searching only to find that the most common solution is to execute a console command on start-up. Is there no other way to set the resolution the game runs at? Am I missing something somewhere in the options? Or is setting the default resolution of a packaged game not possible without doing something in code or blueprint?

I used this example and it worked out for me very good. It took me a bit too understand it, if you hit some problems let me know here so I can walk you through but its good to read through to know where things are: How to - FULLSCREEN - packaged build? - Platform & Builds - Unreal Engine Forums

This worked, thanks. I had tried this before and couldn’t get it to work, but I had originally missed the part where you add “Default” to the file name. I find it weird that Unreal doesn’t have an option in the project settings UI for setting resolution, but this work-around will work for now.

@kdd9000 I agree. Why can it not be in the editor?? Is it because these settings are loaded when the editor loads? Baffled.

Hello kdd9000 & rich2020,

Despite the delay, I’ve played a feature request in for this as I believe it would be useful to have that level of accessibility. For reference, the report’s number is UE-27079. I’ll be sure to let you know if there are any updates on the request. Martin’s workaround would be your best option in the meantime.

Have a nice day!

Will this be added to 4.16?

Amazing Engine, Thanks Epic!

hey please tell me how to do this ???