How can I set player collision to the mesh instead of the capsule?

I’m building a character controller with a static mesh as the visible character component but it keeps referencing the capsule component for the collision. I’ve attempted to resize the capsule component to fit around the mesh with very limited success. Is there a way to get the character to base collision off of the static mesh instead of the capsule component?

Have you turned the capsule collision off?

When you created your player controller blueprint, did you base it off the pre-existing player controller blueprint templates? You could try basing it off of Actor or something without some of the extras the player controller probably comes with.

In the component section of your blueprint theres a series of components, select the capsule component and just turn collision off in the details tab (remember the setting it was on for the switch). After that select your mesh and set the collision to what the capsule had.

That should make the mesh the collision detector instead of the capsule.

I hope that’s what you were looking for

Still struggling with this in 2015… No solution yet