How can I resolve this error?

When I build my project it and then start it I get this error message


After I click on “OK” the project opens and everything functions as it should, still it is a bit annoying.
How can I fix it?


Your EditorSphere mesh is MIA!

In the launcher, in the drop-down next to ‘Launch’ you can run ‘Verify’

This will check all editor files and replace any missing ones (like the EditorSphere)

Welcome to the Forums, let us know if you need any help changing your Forum display name.

1 Like

thanks for the suggestion. It took some time to verify UE and Package the Project again, but sadly I still get the same error…

Also it would be great if you could help to change the name since it seems that I cant do that :sweat_smile:
When I try to click “edit profile” it redirects me to a site that “does not exist or is private”

from the source compile of ue 5.1

EditorSphere.uasset (142.0 KB)

It’s a quick fix but other files may be damaged if this one is missing.

1 Like

Whats weird is, that when I go to Engine\Content\EditorMeshes the EditorSphere is there
and trying to import the EditorSphere from you tells me “unable to reimport mesh”

so I don’t really understand whats happening here

in the source of the CDO of gltfmaterialexporter.cpp

UGLTFMaterialExporter::UGLTFMaterialExporter(const FObjectInitializer& ObjectInitializer)
	: Super(ObjectInitializer)
	SupportedClass = UMaterialInterface::StaticClass();

	static ConstructorHelpers::FObjectFinder<UStaticMesh> DefaultPreviewMeshFinder(TEXT("/Engine/EditorMeshes/EditorSphere.EditorSphere"));
	DefaultPreviewMesh = DefaultPreviewMeshFinder.Object;

Seems to be a hard path from the engine base directory +
/Engine/EditorMeshes/EditorSphere.EditorSphere. Check if it’s there.

Also if you have multiple version installed then make sure you are looking in the right engine directory (you can check with the switch engine on your .uproject)

1 Like

it seems to be there

Is the file size similar to 142 KB? (could it be damaged having 0 bytes?)

1 Like

if you mean the EditorSphere.uasset then yes, its 143kb
or is that 1 additional kb a problem? its actually 142kb when clicking on it

okay so I stumpled across this reddit post:

It seems like disabling the glTF plugin or cooking the editor content when packaging will fix this issue until 5.1.1 is released and this issue is fixed (if what is said in the reddit post is legit and the devs are aware of this issue)

I tried cooking the editor content and it worked for me - however this adds a bit of size to the packaged project.

1 Like

I found a workaround until the issue is fixed (hopefully) but thank you so much for your time!