How can I prevent my control rig foot IK from becoming 'squishy' when baking the animation sequence?

As you can see the foot IK is working flawlessly with the control rig, but when the animation is baked the IK becomes “squishy,” bouncing up and down when it should be firmly in place.

Any ideas?

Possibly check your skeleton settings. make sure nothing is set to Scaled except the pelvis.

Other than that, just don’t use the engine for making animations…

Thanks for the reply. My pelvis is already set to animation scaled and everything else is skeleton. I tried setting the pelvis to every other option and baking with no luck.

I would really like to be able to use control rig for multiple reasons.

To cause the feet to move, either your root bone or the pelvis is shifting down more than it should.

I’d suggest debugging in blender by activating visual bone tracks to see exactly who is moving and how. (Note that the feet will also show motion, but they don’t necessarily move differently than intended).

From that, you first try to fix matematically in blender, and subsequently try to figure out why the engine is baking that way…

It could be that both the root and the pelvis are moving down at the same rate, causing the shift value to double. That’s my impression off the footage anyway.