How can I play a .mp4 intro movie?

Hi, I want to play a .mp4 movie before starting a level. I tried to use the Movies tab in the Project Settings, but when I click the Launch button, and all content is cooked, I see a white window, and then my level loaded, but I don’t see my .mp4 movie.

EDIT: I tried with another movie, and I can hear the movie, but I can’t see it, because I see a white screen when I hear the audio of the movie.

Howdy Scienziatogm,

We are currently looking into the issue that you, and a couple of other users, are seeing with the movies being bugged in the editor. I have reached out to a couple of devs for help with the issue. I will be sure to update you as soon as I hear a response to the issue.

Thanks and have a great day!

Quick question for you Scienziatogm, Would your project be a content-only based project or a code based project?

I tried with C++ based project, with Blueprint based project and with Blank project, but it doesn’t work anyhow.

In 4.2, any Content-Only game is going to be broken for movie playback as the Slate content is not being copied to the game currently. I have spoken to a couple of devs and they have been working on the movie issue and hope to have it resolved in future builds. I am unsure as to what build or date of the build but it is a known issue that is being fixed.

I am unsure as to why the video would not work in a C++ based project as other devs I have asked are saying that the only issue is with a Blueprint based project.

Is the video a h264 file?

Yes, it’s h264, but it doesn’t work. I used the C++ version of the Third Person Template.

Hey Scienziatogm,

With the new 4.3 update, is the video issue still happening with your C++ project? There have been numerous fixes in 4.3 and it is possible that this issue could have been solved in this update. If it has not, Please feel free to let me know.

Thanks for your patience and have a great day!

The issue hasn’t been solved. I tried now.

I have been assigned to a couple other video issues and have entered bug reports for the video playback not playing. The issue is still open currently and has been assigned so that may be fixed in a future build. Please let us know if anything else is needed.

Thanks for your patience!

Added data to this issue. I’ve spent a few hours trying to find a video preset that works correctly for exporting my video from AE->Adobe Media Encoder->MP4 the only one that loads and plays correctly is HD 720p at 25 FPS.

You can try downloading the encoder and processing your video at that preset to see if it plays for you. Also note that I have not gotten any video to encode and play at anything near 1920x1080 the only size that seems to work is the 720 at 25. Please note that 720p at 29.97 does not work as well.

Hope this helps some.

Yes, it works! I hope that will be the 1080p support and a >25 FPS support.

Many thanks for the info,for now i going to star with Unreal Mpeg4 editor i think its coming soon :F

This ACTUALLY works. I couldn’t get any setting in Handbrake to work, so instead used as mentioned above by Shoiko:

Adobe Media Encoder, H264 Codec, Preset is “HD 720p 25”

I’m guessing other adobe encodes work, but I’d love to know why Unreal imports movies which it can’t even play.