How can I package for HTML5

I must be missing something silly. I have installed emscripten, Python 2.7 and edited the html5engine.ini file as it’s said in the documentation but when I press the package to HTML5 option it still send me to the documentation site. How can I solve this so it builds?

Thanks!

Hey Javyer,

Have you clicked on the drop-down arrow beside ‘Launch’ within the editor and managed your devices? Also, have you restarted the engine since updating the HTML5 information within the .ini? If so, could you please locate your HTML5Engine.ini and see if it’s similar to the following:

[Audio]
AudioDeviceModuleName=HTML5Audio

[OnlineSubsystemMcp]
benabled=false

[SystemSettings]
r.setres=800x600

; These following settings have moved to the User inis and can be set from the editor
; These old value are left as reference until all old code paths are removed
;[BuildSettings]
;HeapSize=1024

;[HTML5DevicesWindows]
;Firefox Nightly (64 bit)="C:/Program Files/Nightly/firefox.exe"
;Firefox Nightly (32 bit)="C:/Program Files (x86)/Nightly/firefox.exe"
;Firefox (32 bit)="C:/Program Files (x86)/Mozilla Firefox/firefox.exe"
;Firefox Aurora  (32 bit)="C:/Program Files (x86)/Aurora/firefox.exe"
;Chrome="C:/Program Files (x86)/Google/Chrome/Application/chrome.exe"

;all browsers on mac are 64 bit, 64 bit browsers can allocate more than 512MB of memory to around 1.5 GB. 
;[HTML5DevicesMac]
;Safari="/Applications/Safari.app/Contents/MacOS/Safari"
;Firefox="/Applications/Firefox.app/Contents/MacOS/firefox-bin"
;Firefox (Aurora)="/Applications/FirefoxAurora.app/Contents/MacOS/firefox-bin"

;[HTML5DevicesLinux]
;Firefox="/usr/bin/firefox"

;[HTML5SDKPaths]
;Mac="/path/to/emscripten/sdk"

Looking forward to hearing back from you, thanks! :slight_smile:

Hey Javyer,

I have not heard from you since your initial post and for this reason, I must resolve this post at this time. However, if you have any further questions regarding this topic, please feel free to reply back here. For any other questions, please post a new question to AnswerHub.

Thank you and have a nice day!

Hello! Thanks for answering!(And sorry for my delay)

This is my .ini, I believe everything in it is correct.

[Audio]
AudioDeviceModuleName=HTML5Audio

[OnlineSubsystemMcp]
benabled=false

[SystemSettings]
r.setres=800x600

[BuildSettings]
HeapSize=1024

[HTML5DevicesWindows]
Firefox Nightly (64 bit)="C:/Program Files/Nightly/firefox.exe"
Firefox Nightly (32 bit)="C:/Program Files (x86)/Nightly/firefox.exe"
Firefox (32 bit)="C:/Program Files (x86)/Mozilla Firefox/firefox.exe"
Firefox Aurora  (32 bit)="C:/Program Files (x86)/Aurora/firefox.exe"
Chrome="C:/Program Files (x86)/Google/Chrome/Application/chrome.exe"

;all browsers on mac are 64 bit, 64 bit browsers can allocate more than 512MB of memory to around 1.5 GB. 
[HTML5DevicesMac]
Safari="/Applications/Safari.app/Contents/MacOS/Safari"
Firefox="/Applications/Firefox.app/Contents/MacOS/firefox-bin"
Firefox (Aurora)="/Applications/FirefoxAurora.app/Contents/MacOS/firefox-bin"

[HTML5DevicesLinux]
Firefox="/usr/bin/firefox"

[HTML5SDKPaths]
Mac="/path/to/emscripten/sdk"
Emscripten="C:/Program Files/Emscripten/emscripten/1.29.0"
Python="D:/Stuff/Development/Python-2.7"

In the application manager doesn’t appear anything about HTML5, and yes, I even restarted the machine.

Hey Javyer,

Did you click on the drop-down menu beside ‘Launch’ and look in the Device Manager? If so, are you able to claim the HTML5 platform for each web browser you have installed on your computer? Have you also looked in Project Settings under Supported Platforms and chose ‘all platforms’?

Looking forward to hearing back from you, thanks!

I can’t claim any HTML5 platform

It is listed as supported on Supported Platforms, this is the reason that confuse me, I don’t know if I have to change something else.

Hey Javyer,

What is listed under “Platform Filters”? Also, does HTML5 show up under “Add an unlisted device”?

Platform Filters

45022-captura+de+pantalla+2015-06-02+17.11.19.png

Add unlisted Service>Select Platform:

45024-captura+de+pantalla+2015-06-02+17.11.16.png

As you can see I don’t have the option for HTML5 anywhere :frowning:

Under platform filters: Windows, iOs and Android and in Add an unlisted device it doesn’t appear HTML5, only different versions of Android, Windows, iOs and Linux.

Hey,

I’ve spoken with our developers and it looks like your Python may not be looking at the correct file, it’ll likely need to be set to this: Python=“D:/Stuff/Development/Python-2.7/python.exe”.

Please let me know if this fixes the issue you’re running in to or not. Looking forward to hearing back from you, thanks! :slight_smile:

Hey Samantha,
Thanks for getting so involved with my particular problem! I tried changing the .ini as you said and it didn’t work, I will try reinstalling python to see if something went wrong during the installation.

You’re very welcome, please let us know if it doesn’t work out again. I’ll ask the developers for additional assistance at that point in time.

Looking forward to hearing back from you, best of wishes. :slight_smile:

I changed

Emscripten="C:/Program Files/Emscripten/emscripten/1.29.0"

To:
Emscripten=“C:/Program Files/Emscripten/emscripten”

And now it appears on the Device Manager the HTML5(Chrome and Mozilla) option, but I’m still being redirected to the documentation page when I try to package, they also don’t appear on the launch dropdown menu.

I tried changing the python path to python.exe but I’m still being redirected. At least I was able to solve a little from this problem :slight_smile:

Hey,

Did you try reinstalling emscripten? I sent a message to our HTML5 developers, but I also saw a few other AnswerHub posts stating that reinstalling emscripten actually fixed their issue.

I’ll let you know when I hear back from our developers too. :slight_smile:

It worked!!!

I found out the reason(it’s really silly)

The path in the documentation page says 1.29.0, the new version is 1.30.0. When I downloaded I instaled the latest version and that’s why it didn’t work. The documentation page should be update. It’s just a change of 2 numbers in the .ini file :smiley:

Thank you a lot Samantha for your support.

I finally figured out. The reason why it didn’t work was because the path

Emscripten="C:/Program Files/Emscripten/emscripten/1.29.0"

was outdated. The new version of Emscripten is 1.30, so the new path should be

Emscripten="C:/Program Files/Emscripten/emscripten/1.30.0"

Hey Javyer,

I’m glad that it finally worked for you. Anytime that the version is upgraded, the .ini file is going to need updated too from the looks of it. I’ll pass the information along. I’m not sure if the 1.29.0 is set there as an example or not. :slight_smile:

Have a wonderful day, and good luck with your HTML5 project!!

i also have the same problem when i package APK file

i have the same problem,when i package in apk file.
the problem still can not handle.