Download

How can I mute sounds for certain items?

Hello.

So, currently the generator and fabricator are so loud it makes me not want to play.

The constant buzzing of the generator makes me get anxiety for some reason.

I’ve been playing this amazing game since release and I simply removed the files and it’s been great!

Today, after the most recent patch the game crashes if the files aren’t there…

So, how can I solve this?

I simply want to mute the sound for the generator and fabricator so I can play and have fun again :).

This is really important for me. It may sound silly that the sound for the generator can put me off playing but sadly its the truth.

[HR][/HR]
Solution:

Remove PrimalGameData_BP from ContentStreamers folder.

I facepalm that it never hit me earlier. I thought “maybe since the files are now cached and if I remove the referrer it can’t find the file anymore. By removing cache I can safely remove referrer”

I’m so insanely happy, like seriously, no more anxiety over monotony sounds! I know it might sound crazy that it can make a person not wanna play but the same sounds for a long period of time makes me seriously depressed.

Since I run the game on an SSD it’s already as fast it can get so I don’t benefit from the caches anyway!

Is this for a server (other than your own) or local? And what was the path of the files that you removed before?

Okay, so basically the only thing you would need to do is find the Generator and Fabricator blueprints and just simply remove the sounds for activation. This will however require you to cook out the mod and upload it like a normal mod would be. So if you wanted this on a Unofficial Server or Official you wouldn’t be able to. Unofficial you could, but it would require the owner of the server to implement it for you.

If this is just for single player then this will work fine

  • Sinari

Forgot to mention but I play on a official server.

So, since release I simply removed the files (ARK\ShooterGame\Content\PrimalEarth\Sound\SFX\Structures\HiTechPW_gen_generator_start_Cue.uasset for example) and the sound for the generator/fabricator were gone!

I’ve been having a great time with no buzzing but sadly, after the patch this early morning (the most recent patch) the game now crashes when the files aren’t there.

So, what changed? Am I now unable to mute those sounds or are there another solution?

I’m not sure there is any way without manipulating the sound files themselves. I also don’t know if that is something that could be picked up by VAC, so I’m a little hesitant to try it out. But I was able to export the .WAVs and silence the audio.

Yea, I played around a lot in the editor.

So what I’ve tried is that I went into the editor, marked the files, edited and muted them, saved and copy-pasted in the ark folder but that doesn’t seem to work.

I then replaced all files with empty txt files that I named as the files were named, that didn’t work either, there were still sound that is.

So, it doesn’t really help that you can export the files and extract audio because you still gotta import it and then make it .uasset again?

Also, VAC doesn’t work like that so there’s no worries about getting banned.

If these were exe or dll files however.

Hmm, I don’t know actually how this would be done at all for a Official server. Sorry, wish I could of been more help :confused:

  • Sinari

You can try these: MEGA

Just overwrite the ones in Sound\SFX\Structures\HiTech (of course make sure to backup). I’m not sure if this will work or not. I wish there was another way to do this. I haven’t tested it and don’t recommend changing files but if you are really out of options, I guess it couldn’t hurt to try.

Sadly didn’t work :(. The generator were still buzzing.

I guess you don’t need to edit the cue files as well, no?

Not really sure. I’ll keep poking around at the files and see what I can do.

Cue files generally don’t need to be edited UNLESS it is referenced by your edited asset. Only then does it.

There’s really no way to solve this?

This gives me anxiety… I can’t play the game with the buzzing :(.

I wonder what they did in the patch.

Oh well, I won’t play on anything else than official so not sure what to do.

I’m really not sure Snicker. Sorry, I wish I could be of more help :frowning: This in kind of slightly in the realm of modding, but then also isn’t at the same time, which makes it tricky to come up with a plausible/attainable resolution. What you want to accomplish I don’t think is possible currently on Official servers, but again, I have never fiddled with any of the client side files in terms of anything surrounding this or anything even related to this >.<

  • Sinari

I just have to deal with it then I guess. I don’t wanna stop playing this amazing game.

So they have simply done some something in the patch that requires all files to be there…

Thanks for all replies :).

I mean you could always just turn the sound down or off while you are near those structures. I know its a pain, but at the moment it seems to be the only solution.

I solved it :D!

Solution:

Remove PrimalGameData_BP from ContentStreamers folder.

I facepalm that it never hit me earlier. I thought “maybe since the files are now cached and if I remove the referrer it can’t find the file anymore. By removing cache I can safely remove referrer”

I’m so insanely happy, like seriously, no more anxiety over monotony sounds! I know it might sound crazy that it can make a person not wanna play but the same sounds for a long period of time makes me seriously depressed.

Since I run the game on an SSD it’s already as fast it can get so I don’t benefit from the caches anyway!

Wooo! Nice job on finding a work around. I had contemplated that, but figured that would screw things up. Interesting fix :smiley:

Very happy to hear you found a fix! I actually enjoy the white noise personally with machines & things, but I can understand completely what you mean about it effecting you like that.

  • Sinari