How can I make animation transitions smoother?

You can actually put in an offset on an animation. So technically you can move the whole animation up a few units on the import.

  1. Open the Animation

  2. Go to the Anim Asset Details (default in the lower left panel)

  3. Click on the “Reimport” category, then Transform.

  4. Input your Translation/Rotation offset.

  5. Save and then hit Reimport.

The offset won’t take effect until you reimport.

Hope that helps =)

Which specific animation pack did you get this from? The proper fix would likely be to zero out the transform on the root bone out of the source animation. If I’m seeing it correctly it looks like there’s a rotation and location offset on it. If you can’t edit the animation a quick and dirty fix would be to remove it in Persona (additive layer track) or not use root motion for that animation (assuming the starting point and ending point are at the same location).

Overall though it looks like it was made with a bad transform on it. If that was generated during re-targeting the skeleton, importing, exporting, or just poor animation work I do not know.

Edit: rewatched it a few times, the root is below 0, hopefully Devero’s suggestion will fix it!

Hi! Firstly, take a look at this video I uploaded of my project, the problem is easy to spot.

To put it into words, there is no blending between my idle/walk/run animation and my throwing animation. The feet go into the ground, the entire pose changes… it just looks quite ridiculous.

My question is: how do I get it to be more smooth?

I’ve done some thinking into the problem… I’ve seen how the blendspace works for the idle/walk/run animation, and I’m wondering if blendspaces are the way to go to fix this problem, so I went ahead and created one, and now I think I can see why my character dips into the ground while transitioning between poses. Take a look:

I got this throwing animation from a market place mega animation pack, so it’s odd that the root bone is so different at the start of each animation…

So after seeing these two videos, how do I go about fixing this problem?

Thanks in advance for any help :slight_smile:

Hi! I got this from the MovementAnimsetPro pack - Upon you saying that I checked the FAQ’s on the marketplace

Just my luck, eh?

Not sure if I’m going to be able to export it and fix it myself in maya…

Hi! I tried what you suggested and imported it with a setting on -20 on the Z axis, although it fixed the fact that the animation hovers off the ground, it doesn’t fix the actual problem which turned out to be bad motion re targeting in 4.8 (see the other answer)

Hi, so did you get this fixed? I struggle with this too… just with the free animation starterpack and the thirdperson standard movements. They apparently also have a difference in how the root bone is oriented.

Im in 4.10 and still retargeting does not fix this mis-orientation, so either it’s something i need to fix in Maya (which i don’t know how to use) or maybe someone else knows a way to do it?