How can I make a material not rotate when rotating an actor?

Hi! I’m using a modular asset pack and the floors come in 1x3, 2x3 and 3x3 sizes, but to make it fully work I have to rotate some of them. Issue is it’s a wooden plank floor, so I can’t rotate them 90º.

Is there a way to prevent the material from rotating with the actor?

I also remember from many years ago in UE4 I could cut parts of boxes using other boxes turning a setting on but I can’t remember what it was and I don’t know if that can be done with all actors.

1 Like

You have to edit the material, basically.

Do one of

  1. Put a rotator node in the material so you can rotate the textures with a parameter
  1. Make the material world aligned, then it never moves, even when you rotate the actor
1 Like