How can I get Unreal Engine 4 to detect Visual Studio 2013?

Unreal Engine 4 will not see that I have Visual Studio 2013 already installed. How do I fix this? I have ultimate and do NOT want to use Express.

Could you please check that you have a %VS120COMNTOOLS% environment variable. This is what UE4 uses to find Visual Studio installations.

Mine is pointing to C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\Tools, and my devenv.exe is at C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\devenv.exe (we look for %VS120COMNTOOLS%…\IDE\devenv.exe to detect Visual Studio Pro/Ultimate).

Thanks a lot Jamie. It seems I needed to install IE10 and then restart the PC and now it’s working, UE4 is seeing VS just fine :slight_smile:

I would like to know more about what you mean, however. I am completely new to programming and game developing. I’m not sure what an environment variable is though the term sounds familiar. For future reference’s sake, if you could tell me how to check to see what mine is pointing to what you mean by that, I’d be very grateful. Thanks again.


If you right click on “Computer” and go to “Properties”, then you can go to “Advanced system settings”, and then “Environment Variables”.

This brings up a UI showing all of the environment variables set on your system. The VS common tools environment variables are under the “System variables” section.

This doesnt appear to be working for me. I have VS 2013 express istalled on my E drive rather than C, and I have the environment variable setup correctly to point to the tools folder inside the IDE directory for VS. I’m not sure why it is not picking up on the VS install at this point. Anyone have any idea what I should do?

Me either , did you find a solution?

Not working for me either. Environment variable is set correctly…

Are you using UE 4.10?

Also experiencing this.

All variables appear to be set correctly.

We’re using 4.10.

After more poking around it seems that it was actually after VS 2015. Wrong error being shown?

Any fix, any news? Doesn’t work for me either.
All paths are right, and I’m on 2013 visual too.

Hi Everyone,

This is my first thread in this board, so thank you in advance for your help.
I downloaded and installed a prebuild version of the UE 4.10 (via the Launcher). A VS-2013 Community (Update 4) is already present on my Windows 10 (x64) system. My variables are set correctly as suggested before but the UEEditor is complaining about the “missing compiler”. Is there a workaround found for this?


The version of 4.10 downloaded from the launcher actually needs VS2015.

even with 4.10 and VS2015, I can’t make it find the compiler. I also checked out the environment variable and it was correct (by the way, it was called %VS140 instead of %VS120 but I tried changing it to 120 and it still gave the same error)

I’m having exactly the same problem but it seams that only when I have Rama’s victory plugin installed. If I remove it then it works. Check to see if you have this plugin.

I have 4.10.4
Visual Studio 2015 Community.

With Rama’s plugin I get the message prompting me to install Visual Studio.
Without Rama’s plugin it builds fine.