How can I get my animation into UE4 from Blender?

My simple gun is rigged and animated in blender. I exported the file as fbx. When i import it in my animation is messed up. Link:( I really am frustrated, please help…

Hello, Friend!

What version of Blender are you using? Blender 2.7 was released just here recently, and “has a lot more support for Exporting FBX files”.

There is a lot of discussion here over importing FBX from blender to UE4.
Doing some (very) basic digging here on UE4 AnswerHub; I was able to find THIS and THIS.

The first link posted seems (to me) to be the most informational. The tutorial covers Maya and Max, but the same basic principal should apply.

I hope this gets you started looking in the right direction until one of the wonderful Pros here stops by for a looksee.
If, this helps you find a solution, please post it as an answer on this thread!

Good luck!


Import it having AsTOSRef enabled, and it should work.

mdmoberly, probably has the best solution.

that doesnt work, I have already tried that.

Thank but what you saiid doesnt really help. Any other suggestions?

I tried and it works fine for me, but I think I know what caused it. It was reference pose having scale. We fixed this internally, so with next release, this should be fixed. But if you need workaround until then, if you make sure all scale to be 1. Or next release will fix the animation issue. It will require reimport.



Most of my problems i have fixed by doing the following:

C:\Program Files\Blender Foundation\Blender\2.70\scripts\addons\io_scene_fbx ← open this

comment these lines away. by putting # infront like example below.
then save it. (if it doesnt let you, make sure you are running as administrator)

2525 #else:
2426 # the armature object is written as an empty and all root level bones connect to it
2427 #fw(’\n\tConnect: “OO”, “Model::%s”, “Model::%s”’ % (my_bone.fbxName, my_bone.fbxArm.fbxName))

and scale model by 100x inside blender.

Convert model to newer version to get rid of other errors aswell.

Credits go to a guy named Geo Dav for finding this fix that worked for me.

It seems to be actually broken now ^^