How can I get Epic games Launcher AND UE4 to run on Windows 10

Included in this is also UE4 10.0

I have tried everything I know to try.

I even changed folder permissions

trying to open the launcher does nothing. In the task manager it does show it open, then it closes in less than a second. I can only open it using the -OpenGL modifier in the shortcut. If I use the _openGL modifier, then UE4 (any Version) gets to initalizing about 18% then it closes. Creating a shortcut for UE4 and adding the -OpenGL modifier to that will launch the editor. but it cannot package or load anything. So I waited for updates but none helped.
Windows says “Incompatible program” in its useless troubleshooter.

I have the latest drivers (clean Installed)
I have re installed multiple DirectX version packages.
Here are my logs
link text
If you have anything else I can try It would help greatly.
Thanks in advance

  • Jeffrey Kretzler

If you have Windows 10 and a GeForce 980 and have installed the latest version of DirectX why are you trying to use OpenGL if you don’t mind me asking since DirectX has nothing to do with OpenGL besides it being a non Windows/Proprietary API. Are you needing OpenGL for something you are working on in the engine? I am a bit confused here.

Did you upgrade form Windows 8 to Windows 10? Just reading through part of your logs and noticing the engine is referencing Windows 8 in the crash context. This could lead to unhandled memory exceptions when UE4 tries to load modified dlls. It could very well be possible that your UE4 installation still believes you’re running on Windows 8. I have Windows 10, I7 Quad, and a 770m which is similar to your set up and have no issues.

Hello Keiyentai, Thank you for your help.
The software does not run in DirectX at all. I can only get it to open in openGL mode. Even then, it does not want to open any projects. and it won’t compile anything.

Hello zacharymwade,
Yes this was an upgrade. This is an issue I haven’t noticed and will probably put me on the right track to fixing it.
I am hoping I will not have to perform a clean install of windows 10. but I don’t personally know of another way to fix this specific issue.

Just delete the engine + Launcher (but save your content first) and download it again for the right Windows version.

I agree with Fragment7. Backup your project and content and do a clean install of the engine and launcher. I am kind of perplexed as why it would act this way cause I upgraded from 8.1 Pro 64 to 10 Pro 64 and no problems with DirectX. Other thing you might want to try is just to make sure something didn’t go odd is download the DirectX runtime again and see if maybe something for some odd reason didn’t copy over correctly.

Hi Killerfishmonkey,

I’m sorry to hear that you are having trouble. Are you able to generate your DEBUG logs? These are going to be more verbose that the standard ones you provided. You can find the steps to create there here.

Here is the full set of logs after a clean install of the engine
link text

Hi Killerfishmonkey,

Thank you for the information. We are looking at your issue now. What antivirus and/or network monitoring software are you running? Have you attempted to run the install as admin with the AV disabled? I’m currently working on anther ticket with a very similar issue.

Currently I am only using Microsoft security essentials, and Eset online scanner once a while. I use Malware bytes anti malware.

Hi Killerfishmonkey,

The error I’m seeing in the logs in most commonly associated with interference from a malware or AV scanner. Can you please try running the launcher with MS security essentials and Malwarebytes temporarily disabled? If that does not work, please uninstall the launcher then reinstall it with MS security essential and Malwarebytes temporarily disabled during the install and the initial running.

This did not work which was surprising. I have enabled debuglogging and attached more logs. Thanks for helping link text

Hello Everyone!
I fixed it.
This is how I fixed it

I manually deleted every DirectX .dll file
d3d9.dll all the way to d3dxof.dll

also was
X3daudio_01.dll to Xaudio2_9.dll

re installed the directX websetup from microsoft and now it works.

I will let you know once the engine is downloaded if I run into any more issues.

The launcher is working now. the Eureka moment for me was trying to run a video game. The specific game is Far Cry 4. It did not launch either and kept giving me an error 0xc000007b. troubleshooting led me to problems with directX. I posted an answer below detailing the exact steps I have taken. Thanks for your help.

Is this working? I rolled back from W10.

Hello MrMrC, Yes it is fully working. I just ran and packaged the infiltrator demo to play with on my machine. If you need anything let me know.