How can I fix sharp dark shadows on wall and cveiling corners ?

Hi everyone!!

I think Im getting the hang of using Unreal but one thing still bothering me.
No matter the light quality the wall and ceiling corners always have these sharp shadows that make it look unnatural.
I first tried removing ambient occlusion, increasing light bounces to 100, increasing sky light intensity and improving the world settings, but didn’t worked. Now I discovered that by overriding the light map res to 1024 (density of red) or more reduces it but the render time increase exponentially. This reduces it but still keep a thin dark line.

I think it have something to do with the lightmap resolution or the lightmap UVs, but if so I don’t know how to solve it.

I have seen various demos I downloaded and the light map res is very low and don’t have this problem.

Please somebody help.