How can I fix outline effect using depth fade?

Hi everyone! My issue is a creepy white outline effect when the static mesh with unlit or lit material placed in front of the mesh using translucent material with depth fade node. Without depth fade node it’s all ok. But if I need to create realistic water or fog I need use this node to create blurred transparent contour. Also outline effect is absent if the mesh placed in front of water use translucent material too (look the screenshot), but I can’t use only translucent materials in my scene.
Is this a way to fix this effect using depth fade node? Thanks for the answer!

I bumped into this issue as well. Did you ever find an answer?

I have the same problem and I’m looking for a solution

you need a proper outline material

Solved it, MSAA is causing this when using a depth mask, setting it to off gets rid of the thin white outlines against bright backgrounds

Without and with msaa4x: