How can I eliminate screen tearing while in fullscreen?


I’m getting strong screen tearing when running my game in fullscreen mode. Is there any way to force vsync or something that prevents that? I’ve already limited my FPS to 60 with no success.


Hi anteevy -

Are you getting any screen tearing in the editor or when you PIE? Could you post a screenshot of the actual tearing so we can see it? What is your video card and driver information as well?

Thank You

Eric Ketchum


I’m not getting it in PIE because I can’t maximize the PIE window. When choosing Play → Standalone Game and then maximizing the window with Alt+Return I get the tearing. Same thing with the built game (via “Launch” in the editor). Any screenshots or videos (with ShadowPlay) I take don’t have the tearing I see while recording them, so I can’t show you…

I’m also having some minor stuttering for 2-3secs every 10-15secs (though the FPS don’t change at all!) but I think that is another issue.

Hi anteevy -

This sounds like a video card driver issue. It may not be but it sounds like one from what you have described so far. Could you try to update your drivers and let me know what card you are using? It will also help us narrow down the cause of this tearing issue.

Thank You

Eric Ketchum

I have a GTX760 with the latest drivers. However, I just had the idea to force VSync in the driver and both the tearing as well as the occasional stuttering are gone! :slight_smile:

Is there a working solution to force vsync in the game? Calling “r.VSync 1” as a console command does not work, neither does “-vsync” as a command line parameter and I can’t find an according .ini setting string.

Hello guys,

I was just about to post the same question but i just saw this thread and i would like to inform you that i have the same issues with my cooked game.
During PIE either as a standalone window or as a standalone game the game runs perfectly.The second i export it, i have this terrible screen tearing .I have tried it in 2 different systems ,one with a 7870 and the other one with a r9 290 both of them with the latest drivers and i had the exact same results.Both systems run the game at a constant 62 fps.

Did you find what is causing this?

My game is unplayable and something must be going on since i have no such problems during PIE.

Thank you.

EDIT: I forgot to mention that even if i set “Wait for vertical sync” to Always on from within the catalyst control center nothing changes.

Have you set “bUseVSync=True” in your DefaultGameUserSettings.ini?

You can try turning on adaptive v sync in Nvidia control panel, its under 3D settings> vsync> change to adaptive. This way your graphics card will use vsync automatically if tearing is detected vs. Relying on game settings.

Hello , did you find a solution? I have exactly the same issues

i’m having this issue as well, but only with one level. the level runs at a smooth 60 fps with vsync on and with frame rate well beyond that with vsync off, but tearing occurs in stand-alone mode or packaged build in either case. PIE is fine. this is with the latest drivers from nvidia on a GTX980. tried adaptive and let program decide options. neither fixes issue. will probably wind up rebuilding the level from scratch because ‘save as’ doesn’t fix the issue. hopefully i’ll be able to pinpoint the issue from there.

cross referencing issues / potential dupes:
Similar Issue 01
Similar Issue 02