How can i download Ue 5.2 ?g

It says there are source codes on github, but I couldn’t find it, can someone help me? how do i download unreal engine 5.2


First you must link your Epic and Github accounts.

Then the ‘Main’ branch would be considered 5.2 at this point

Good luck!

April 17 Edit: 5.2 is now available in preview on the Epic Launcher, you no longer need to link your github account and compile source.

1 Like

i tried
1-Install GitHub Desktop for Windows then fork and clone our repository .
2- Install Visual Studio 2019 .
3 Open your source folder in Windows Explorer and run Setup.bat. This will download binary content for the engine, install prerequisites, and set up Unreal file associations.On Windows 8, a warning from SmartScreen may appear. Click More info, then Run anyway to continue.A clean download of the engine binaries is currently 20-21 GiB, which may take some time to complete. Subsequent runs will be much faster, as they only download new and updated content.
4Run GenerateProjectFiles.bat to create project files for the engine. It should take less than a minute to complete.
5 Load the project into Visual Studio by double-clicking the new UE5.sln file.
6 Set your solution configuration to Development Editor and your solution platform to Win64, then right click the UE5 target and select Build. It may take anywhere between 10 and 40 minutes to finish compiling, depending on your system specs.
7After compiling finishes, you can run the editor from Visual Studio by setting your startup project to UE5 and pressing **

F5** to start debugging.

but still installed 5.1
can you help

1 Like

Its the ue5-main branch

1 Like

whats mean this ?

In-editor you can hover over your project name to confirm that you’re on your intended CL. (In the future, they will branch from main into 5.2 release branch, I’m not sure when main will be updated.)

I’m curious to know what reason you have for wanting 5.2.

I’m guessing that error is from running Setup.bat? It looks like an internet-related problem. Maybe a temporary outage on the cdn server?

1 Like

I tried a few times, it didn’t work, then I continued the process and it worked without any problems. I made a video for this I hope it helps everyone ^^

I will be glad if you comment ^^

1 Like

For anyone looking to install 5.2 preview you can install it through the Epic launcher just click the plus button and when whatever version shows, click the down arrow and choose 5.2 preview and install (NO GitHub NEEDED).


I only can Download 5.1.1 in Epic

1 Like

I have installed 5.1.1, and I want to install 5.2.0 beta, but after clicking the + sign, it only shows 5.0.3, and there is no option for 5.2.0 beta.


Having the same issue. I wonder if they’re planning to release 5.2.0 within the next few hours (or even days)?

I just changed my epic account to log in to epic and clicked on the + sign to install 5.2.0 preview version 2

Does not show the installation of 5.2.0, probably a bug in the epic client
I just logged in again with a new account and it shows the 5.2.0 installation normally

[quote=“1466724, post:10, topic:740687, full:true”]
I have installed 5.1.1, and I want to install 5.2.0 beta, but after clicking the + sign, it only shows 5.0.3, and there is no option for 5.2.0 beta.

@1466724 @Jaskowicz @LiLoTVgermany
I was having the same issue and not seeing the 5.2.0 option on my Epic Launcher.
What finally fixed it was just downloading and installing the launcher from the official site.

However now the issue is that although I can add 5.2.0 to my Engine Versions, the “Install” button doesn’t seem to do anything. Praying for a magic update to fix all this lol.

I have the same issue. Updated the client for 5.2.0 preview 2 to show up. Clicking install does no do anything.

@gabor.papp @guitaroz Hey, in a different thread, someone mentioned that Epic has removed 5.2.0 preview as they’re going to release 5.2.0 extremely soon! It’s a bug that you can still see it but if you reboot your pc it will go away (thats what happened to me)!

1 Like

I’ve got the same issue as well. Has anyone figured it out yet?