How can I disable texture streaming so there is no pop-in for Matinee?

In the video above I’m having an issue where the rocks outside of the window have their textures pop in when the camera is going back toward the door.

Is there a setting or something in the details pane that I’m missing that could stop this from happening?

I would love any advice on this.

Thanks so much!


Hi AndreElijah,

In the matinee window at the very end next to the record button you will see a button labeled “Movie” with a clapboard. If you select that you will see an option to setup some rendering options for your matinee actor. At the very bottom is the option to “Disable Texture Streaming.” This is off by default and turning this on should resolve your issue.

Thank you!


Hey Tim, is this also working for normal matinee play? The movie button holds only settings for recording, so i’m not sure if this works also in normal matinee play…Thanks

Yes this is possible. You would use the console command r.TextureStreaming x (where x represents 0 or 1, I’m not sure about higher values as I don’t use Matinee that often).

You can use Blueprints to execute the command for r.TextureStreaming to set the streaming quality of your textures.

Try just using the value of 1 to start. if that doesn’t work try 2 and so on. Again, I’m not as versed with Matinee so any value above 1 may not work, just test and see what you find.