How Can I disable Box Collision when actor is hidden?

Hi I have a 3dWidget (ActorBP) that is set to hidden in the level BP and will pop up at the end of the level. I have a box collision in the actor BP that you can press to move to the next level. The only problem is that even though the 3dwidget is hidden the box collision is still active allowing the player to overlap that and move to the next level without completing the task. Is there any way to disable the box collision while the 3dWidget is hidden and enabled when it is not?


Yes just set collision of the box to none when you need it. Just get collision and set to none or overlap all or whatever you need.

1st of all thank you for replying. I do appreciate it when anyone takes the time out of their day to reply to one of my posts but I’m a bit confused. It look like you just took my question and repeated it in a different way but not actually giving me an answer so that was my question. How do I turn off (Set to none) the collision of the box when I don’t need it and when the mesh is visible (When I need it) turn it back on.

I don’t know what your set up is, so I dunno if we not understanding exactly what you want to do. But basically when you need it you would enable collision on your collision box and when you don’t need it you would disable it.

Kinda like so: (just using some custom events in my example, but basically when you hide your 3D widget you would disable the collision and when you make it not hidden you would enable it again)


Thats perfect thank you.