How can I disable audio capture component to be listened through my speakers?

I wanted to record the audio of the microphone to save it into a .wav file and I’ve setup an AudioCapture component to output the audio recorded into a Sound Submix to save it later on into a file.

The problem is that I can also hear the audio recorded out of my speakers. I’ve tried to enable the “Output to Bus Only” option in the Audio Capture component, but then it doesn’t record anything.

This is my setup:

273285-audiocaptureoptions.png

have you solved this problem? I want to disable too,thank you very much!

Unfortunatelly, I didn’t found any solution to this problem.

In a slightly different setup where the audio capture component has a post-effect bus send to a source bus, I found that setting “output to bus only” in both the audio capture component and the sound source bus the capture component is outputting to is necessary to stop mic being played back through the system audio output.

So perhaps in your case the audio is being sent to a bus by the submix, and that submix needs to have “output to bus only” enabled? Would have to see more of your project to know for sure.

I also encountered this thorny problem. I don’t know how you solved it in the end?

i’m using the 4.25,just set the Effects-> output to bus only to TRUE in the details of the audio capture.

This prevents the sound from being recorded too, my .wav. file is Null

I also encountered the problem today and didn’t find a solution on the internet, so I had no choice but to try everything possible.

My solution was to create a SoundClass and a Submix. In the submix I set Submix Level>Output to 0.

In my SoundClass I set my Submix as the default Submix.

Then I selected my new SoundClass in the AudioCapture Component.

Now I don’t hear my voice when recording and my sound files have only my voice in them.

1 Like

This worked!

I didn’t quite get what I should do exactly… I am also trying every combination to make it work.

Submix sends but without earing my voice