How can I dampen ambient sounds when indoors?

For example, if the character enters a large cabin in the woods, the sounds of the chirping birds should get quieter the further he gets from the outside walls.

Is there a type of volume that I can use to ‘dampen’ exterior sounds?

Hey Grogger,

You’re probably looking for a Reverb Volume. Under Ambient Zone Settings in the Volume’s Details panel, you can adjust Exterior Volume to affect what the player hears while inside the Reverb Volume.

You can read more about it here: Volume Actors in Unreal Engine | Unreal Engine Documentation

Hope that helps!

Ben Halliday

Thanks for the info Ben,

It certainly sounds like what I’m looking for, but it doesn’t seem to have any effect on the audio in my scene.

I have an ambient sound outside of the reverb volume and my character is inside the reverb volume with the settings attached. I’ve also seen somewhere that I need to rebuild geometry for reverb volumes, so I did that too. (I have played around with the volumes and LowFrequency pass settings as well, but nothing seems to change)

Any idea what I’m doing wrong?

This is still an issue I would like resolved, is there perhaps an example of the reverb volume’s use somewhere?

Hey Grogger,

This issue is most likely related to sounds referencing a sound class that has its Apply Ambient Volumes property set to false. If this is the case, the sound actors in the level will not be affected by the Ambient Zone settings.

  1. Open the referenced sound class (it could easily be found in the details panel of the specific soundwave or soundcue)
  2. Set the Ambient Volumes property to True

5254-image001.png

Let me know if that solves the problem for you.

Ben Halliday

There’s a couple of Reverb Volumes in the Shooter Game maps, if you want to see some in action!

Hey AnXgotta,

The exterior sound actors will be affected without needing to be placed inside their own Ambient Zones so long as they have Apply Ambient Volumes enabled. See the reply I posted above and see if that works for you.

Thanks!

Thanks again Ben, the Sound Class was what was missing/wrong

I LOVE YOU!