Download

How can I change AnimMontage blend time from blueprints?

I have an AnimMontage for a default hitting animation of my character. Unfortunately the attack speed of said character can hit numbers, that don’t let him finish the animation as the blending time of the AnimMontage is longer than the actual animation. If I decrease the blending time, my character teleports a bit when he has only few attack speed.

So is there any way to change the blend time of an AnimMontage as a parameter in blueprints or is there a way to create a new AnimMontage node in C++, that provides blend time as a parameter?

Unfortunately my C++ knowledge is fairly small and I don’t understand all of the UE4 Engines Code yet. I couldn’t find any solution in 3 weeks now, hopefully someone here ran into the same problem.

Did you solve it I have a similar problem

No I didn’t. I asked support and they said they will forward it. I asked around and no one could give me a solution. It’s been more than 1.5years now and I still got nowhere. If you ever solve it, feel free to respond here. Still looking for a solution.

I was trying to make something with the head of my character to look straight in all animations, but I gave up on this as I couldn’t find any solution but in my case it wasn’t to much of a deal cause I found out that my character still look good without this

In the montage editor, inside the asset details tab, the Blend Time is under Blend Option