Hover vehicle's throttle force adds a massive amount of downward torque to the vehicle

I’m trying to implement a Wipeout/Redout like game. Vehicle hovers over the ground using a line trace and upward thrust. But adding forward throttle force gives a big torque to the vehicle. ([Video][1]) I don’t know what’s causing this problem. Probably the bad hover force. Things I tried so far:

  • Manually setting the force location to the center of mass. No difference.
  • Calculating the vector parallel to the floor (Get Unit Direction Vector) and multiplying it by the force strength. Same.
  • Testing with a fixed direction. Still the same.
  • Setting angular damping to 100. Works. But it won’t roll over a ledge. Not what I wanted.
  • Reducing force. Boring and dumb.
  • Reducing upward thrust distance (AKA Line Trace Length). Works. Reduces the torque dramatically. It doesn’t give a smooth ride. Not the physics I want. There’s still a little bit torque though.


Any idea on how to resolve this?

Got it. The problem was with the event tick.

I had a similar problem and the answer “Got it. The problem was with the event tick.” seemed a bit vague for me. After some clicking around I found that the error stemmed from the different types of Tick Groups, that can be chosen from the details panel after checking class defaults. Setting the Tick Groups to Pre Physics in both the hover thruster BP and the ship BP (which handles the forward force) was the solution to my problem.