Download

Hover Vehicle no smooth movement

Hello it’s me again,

ok I try to explain whats going on. I’m using 4 line tracers at the bottom of my racer so that my car hovers over the ground. I read that the Line Tracer works per every frame and I’m calling the event with an Event Tick. The problem is that my speed depends on delta time (see blueprint).

Now if I have full 60 fps everything looks very smooth and perfect. But if frame rate becomes smaller the road is still looking smooth but my racer is lagging very hard, even if i have 50 fps.

So what can I do? Or is there another problem?

Bildschirmfoto 2015-12-11 um 14.46.24.png

Racer speed changes because of FPS difference or line tracers are lagging behind?
One thing I’m not sure about is if InputAxis is ticking the same frequency as Tick event, most likely it is. But regardless of that, this is the description of what FInterp To does:
"Tries to reach Target based on distance from Current position, giving a nice smooth feeling when tracking a position. "
Which is not good because “smoothness” of transition depends on DeltaTime. You can try using timeline for this, or make a small macro where on each step you add a InterpSpeed*DeltaTime to your CurrentForwardSpeed. This way your function should be linear.

So what i found out until now: if i delete the FInterp and use a static value for the forward force it doesn’t get better. I also deactivated the hover components and set gravity to 0 so that the racer ist flying. in this mode I have the same problem. So it has something to do with speed change depending on FPS. What I read is that Function “AddForce” is also called per frame. I’m quite new in unreal and don’t know how to use timelines, but i’ll give it a try.

I found a video that shows what my problem is: as you can see the movement of this car isn’t really smooth. The car is… let me say: “shaking” from the front to the back al little bit all the time. I hope you know what i mean :-D…
https://youtube.com/watch?v=rb8psTcc9WM
Greets Chris

Have you tried calling AddForce from tick instead of InputAxis? Another thing is that AddForce without any kind of drag or velocity dumping should accelerated racer to speed higher than possible to maintain. Check maximum velocity setting and velocity damping of your static/skeletal mesh, perhaps you just trying to super pass it’s limit.

And yes AddForce is effected by your FPS because internally delta time is taken into account when it’s called in physics update.

Terminal velocity:
terminal_velocity.JPG

Damping:
Velocity_Damping.JPG

Another thing to try is higher mass. I had issue with uncontrollable shaking of simulated airplane until I got mass into more realistic scale instead of 100kg as it was from the start.

Yes i tried to call add force within the event tick but it’s still the same as before. Ehm… I can’t find these settings… where do i have to go? I have a pawn class for the racer where i but the static mesh. Here i can not find any settings for maximum values. And if i open the static mesh there aren’t options either…? Or do i have to do this with blueprints? Sorry like i said: I’m quite new in unreal and google doesn’t tell me where i find it…

Terminal velocity is in Project Settings->Physics:
e02d6a64dc8a5052e10315e27fdd6442f2bb9f9b.jpeg

And linear dumping is inside of the actor/character/pawn blueprint. It’s a property of static mesh component:
861e10cb9bac1a5c79eb49f6a5d9d6dec75c5218.jpeg

Okay what i did:

I set the terminal velocity to: 500000000 and i tried values from 0 to 6 for linear dumping -> no effect. then I set mass from 61 to 610. I also adjust the forces for movement and hover components -> the same effect as before.

And your setup is just a box with fixed value of AddForce called on it from TickEvent? This is weird, I have no clue what is going on.
Try to PrintString length of GetVelocity() vector. It will output it into log and on screen, to see if you velocity is actually fluctuating or maybe it’s some rendering bug. Which version of UE4 are you using?

Well i have a very simple static mesh imported from 3ds Max. I will try to use a cube instead. The Racer has a simple box for collisions and in every corner one hover componment for line tracing. I will also Check the velocity. At the Moment i am using 4.7.6 . I heard that 4.10 has Problems with my hover componments…

In that video, it looks like a camera issue. Like they’re trying to set the camera’s position to the car every frame.

Oh my god… that was the right hint. The problem was in the spring arm. I changed every value until i changes Camera Lag Speed. The value of 30 was to high. Choosing a value of 5 or 6 works perfect. Oh man you can’t imagine how grateful i am at the moment. Thanks a lot for your help and support. :slight_smile: <3. Can I mark posts in that forum if a result was found like in the answer hub?

Greets Chris