Hot Reload Isn't Generating dSYM file

I am trying to learn Unreal and am having a problem with using it with Xcode. It seems that I can’t Hot Reload after a few attempts if at all.

Compile Log:

Running Mono...
Setting up Mono
/Users/Shared/UnrealEngine/4.9/Engine /Users/Shared/UnrealEngine/4.9/Engine/Binaries/Mac
Compiling game modules for hot reload
Parsing headers for LineRenderer2Editor
Running UnrealHeaderTool "/Users/[USER_DIRCTORY]/Documents/Unreal Projects/TestProject/TestProject.uproject" "/Users/[USER_DIRCTORY]/Documents/Unreal Projects/TestProject/Intermediate/Build/Mac/TestProjectEditor/Development/UnrealHeaderTool.manifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -rocket -installed
Reflection code generated for TestProjectEditor in 10.1508459 seconds
Performing 4 actions (8 in parallel)
[1/4] Compile TestProject.generated.cpp
[2/4] Compile TestActor.cpp
[3/4] Link UE4Editor-TestProject-6341.dylib
[4/4] sh -c 'rm -rf "/Users/[USER_DIRCTORY]/Documents/Unreal Projects/TestProject/Binaries/Mac/UE4Editor-TestProject-8388.dSYM"; "/Applications/"dsymutil -f "/Users/[USER_DIRCTORY]/Documents/Unreal Projects/TestProject/Binaries/Mac/UE4Editor-LineRenderer2-8388.dylib" -o "/Users/[USER_DIRCTORY]/Documents/Unreal Projects/TestProject/Binaries/Mac/UE4Editor-TestProject-8388.dSYM"'
error: cannot parse the debug map for "/Users/[USER_DIRCTORY]/Documents/Unreal Projects/TestProject/Binaries/Mac/UE4Editor-TestProject-8388.dylib": No such file or directory
-------- End Detailed Actions Stats -----------------------------------------------------------
Info Total build time: 22.28 seconds

I hope someone can help me.


I find it necessary to open my project by double clicking the xcodeproj file in the ~/Documents/Unreal Projects/projname directory, then selecting the scheme of projnameEditor - Mac in the scheme pulldown and clicking the large Right Arrow icon. Any time I make a C++ change, I watch to see that the Hot Reload announces itself back to the Editor. If it doesn’t (or if I immediately get errors in blueprints accessing my C++ objects or odd compile messages), I close the editor and press the Right Arrow icon again.

As of 4.8.x it still required this on Mac depending on the type of changes you make. I just downloaded 4.9.2 this morning, so have not tested it, but I presume this has not been fixed. I’m not presenting this as an answer just in case UE Staff has an answer, I have been hoping the issue would be acknowledged this for several levels now.

Hopefully your issue is resolved by this workaround because it’s not that much of a hassle.

Don’t be shy to post this as a anwser, as it is valid anwser :slight_smile: So i converted your comment. Whatever issue is resolved in satisfactory i leave that to to decide.

That works great. But I agree it seems like there should be a better way.

Thanks , hopefully when they have time, UE 4 Staff will address this. It’s not that important, but is confusing when you first start. I haven’t put a bug report in, because it was reported by someone else a few revs back.

Same issue here, with blueprints and one custom class, no Xcode project just the editor.

Just to see if it’s the same, look in your Unreal Projects directory for a .xcodeproj file and use it to open XCode. Then see if the problem goes away temporarily by opening the editor as below.

Hmmm, no it did’t go away by opening Xcode, but I solved it by deleting the folder Intermediate/Build within the project folder, thanks for the quick reply anyway.

Yes, that was another solution, but it will come back most likely. It did for me anyway. Just in case the Unreal Staff reads this, I’d like to mention that upgrading to 4.9.2 did not fix this issue for us Mac users.

I also used the above method and it worked, but I am finding that when I go to reload the project none of my variables, etc. from my C++ file are available. It just has a bunch of errors and I have to recompile to get it to work. Weird. I’m using 4.9.2

As of 4.12, I still find that the editor has to be closed and reopened after compiling in new UPROPERTYs or UFUNCTIONs or they will not be seen and usable within blueprints. It’s like Hot Reload doesn’t pick these up at all. I am mostly still opening the editor from XCode to get around this. If I add either of the above or change parameters of them, I close the editor and open it from XCode to be certain my changes are reflected. Internal changes (for example to the guts of a class) do not require this, it’s sufficient just to hit the Compile button in the editor and my changes are reflected.