Download

Horrible, visible connections between meshes

Hello everyone,
i have a small ceiling mesh and it is cool and i want more of them, but i guess they don’t like each other and there is something like this between them.

Metallic on


Metallic off

Here’s the texture and material.
981c10678a1010794b0153200b33530e7648afbf.png
8d1fd1fb8833da02db1bee2f0d6128a113963932.jpeg

I have no idea what is the problem. Tried changing lightmap resolution, generating lightmap uv in Max and automatic in UE, nothing works…please help.

It looks like a lightmap issue. Unwrapping UVs for Lightmaps | Unreal Engine Documentation can help you out here.

It looks to me like a normals issue, try disconnecting the normal map and see if it has the issue.

Well it looks better without normal map(and i think i know where is the problem) and then there is obviously a lightmap problem. So both of you were right. Thanks.

To reduce the lightmap seam, take a look at this post, http://www.reddit.com/r/UE4Devs/comments/246whl/the_most_important_thing_about_lightmaps/

Thanks ZacD, interesting post.

I changed some options in my normal map, it is better but there is something very wrong when i change metallic to 1.

Metallic off - small bleeding but it’s ok
b5bdfd33c102a72853f6539c1b252ac0ca0d17a1.jpeg

Metallic on - WTF? (Metallic -1 (whole texture- no mask) Roughness - none)
0a7ed1fd33c070685e6683e35e30f8733f88e53f.jpeg

i don’t understand what is going on.

I assume the metallic is just making the errors more apparent, try putting the roughness to 0 and see if you are getting similar errors. What does your normal map look like now?

If it is a modular mesh, you need to align the edges of your lightmap UV to the grid in order to get rid of this issue. Also, your normals probably need a bit of work as Darthviper suggested based off of the black hexagonal area in the last two photos.

Thanks, i found very helpfull thread about it. Modular Asset Lighting Problem - Content Creation - Unreal Engine Forums

Better normal: (created in PS + nDo. To eliminate problem i changed blend mode of objects from normal to overlay)

And here is material with metallic 1, roughness 0. Brick is just a reflection of floor. What are these triangles? It is a very simple mesh. There is a flat surface where the triangles are showing.

Sorry for my bad english, i understand everything but i have problems with writing. :frowning: I hope you guys understand me.

What about your mesh ?
Try your texture on a basical plane maybe, and check if it’s working

It would probably be best not to over modularize your level in this type of way, unless you have a supporting geometry that will hide the seams.

Lightmass can only adjust the settings so much before you’re fighting a losing battle in this sense.

Using your normal map and a plane I was able to to setup a few examples. The seams will not completely disappear without adjusting the static lighting scale, which I do not recommend unless you know what you’re doing.

For the examples below I adjust the following settings in World Settings > Lightmass

  • Indirect Lighting Quality: 2
  • Indirect Lighting Smoothness: 0.6

These examples use a total of 9 meshes. Three planes for the each wall and the ceiling.

Example one using two lights with radius of 650 and intensity of 5000

This next one is the same thing as above minus the light closest the camera.

In this you can see the seams. This is due to modularity in the mesh. Typically using masking geometry or adjusting lightmass settings can help reduce this. Not always though. Lowering the settings too much will cause other artifacts to appear. This is not a bug, just working within the system to get something that works.

In this last image, I’ve scaled the width of the plane down to half size. You can see the moduarity is exacerbated with the seams.

Without the normal map

94b9c13659864e43d21a8e923604b94afcb82f23.jpeg

The seams are created by Indirect lighting (bounce). In the first image there is enough light in the scene that any bounce blends in and you do not see the seams. When trying to troubleshoot a lot of issues like this it’s sometimes best to start eliminating other factors that may be the cause. For instance, using just a simple base color material you can eliminate other factors like metallic, roughness, or normal values that may exist. If you don’t see the issue with the base, start adjusting or adding in textures until the problem occurs. This way you can start to see where the issue is coming into play.

Some of the problem also appears to be that maybe your diffuse isn’t able to be tiled which looks like part of the seams issue.

Ok, first things first. Thank you all for your help, you are awesome!

Secondly…
The triangles. I guess it was a model problem, i created it again and it is good now.
Thirdly…
In this thread i learned some rules so I will just recreate everything and make the modules a lot bigger

Thanks again.