HMD, Oclus rift, always starting oriented in +x, why ?

I am really at a loss here, I tried a lot of things, but in my project and all the content you provided my HMD is always facing +x when I switch to “Oculus mode” (alt+enter) from a launched windows.

I deleted the config folders from engine, and projects, I don’t find the origin of this.
I always start anything with my rift facing my screen, I tried not facing my screen, 90 etc… it ends up always facing +x what ever the content. ( I tied all the demo, even the VR level, FPS level, all of them )

FYI example :
The content start with correct orientation in “non HMD mode” then it turn in “hmd mode” (after the alt+enter switch)
When I am in OR mode, switching back and the orientation is same as it was in OR Mode. (so re switching to OR Mode doesn’t change orientation again)
To be more “to the point” :
-start a game. Orientation is “as designed”
-OR Mode : Orientation is +x
-Non OR Mode : Orientation is +x
-OR Mode : Orientation is +x

Maybe I will have to reinstall everything, but I am not sure if that will fix it.

My rift works perfectly on any other OUDK content, Unity or demo out there. Never had any problem.
Is it a know issue, I am the only one ? Did I mess up something somewhere ?

Thank you for your insights,


Hey Kris ^^ (you are everywhere !) haha
Yeah the 180 degree is what happened on my project, but this morning I looked for solution again, and went back to check everything. I discovered that X axis constant orientation and added to my post on the forum.
I couldn’t change the title though ^
The thing is I am NOT always facing a direction, when in rift mode only the “initial orientation” change, everything works fine, it’s just that it turn my view to +x.
After that I can turn my head, my pawn etc… no problemo.
I just can’t say or design my level with an orientation in mind : “when the game is launched, the player will be facing : this direction.”
You see ?

Different to what you mentioned on the forum (always facing backwards).

I had this problem - always facing a particular direction - happen when mucking around I had forgot to add the player controller yaw component to the input from the Rift.

Mind you, without a custom player controller, I can’t see how it would have the same cause.

No initial player controller rotation, ok.

But the delta (change in player controller rotation) is making it over.

That is yet another issue I have seen, where using ApplyHmdRotation() is added to the Rift plugins internal rotation, minus the initial rotation. End result, unless the Rift & spawn rotation are the same, you will end up being a certain amount of degrees off.

i.e. If the player spawns facing 0, all is good, but if the player spawns facing 45, your view will always be 45 degress off.

But again, unless the binary version of player controller is wrong or you’re using a custom player controller, that shouldn’t happen.

Oh, btw, change your post is in the wrong place.
Change it from an answer to a comment with the little drop down menu.

Yes (to your i.e example) ^^
The thing is I am not using any special controller on my project, and this happens on all the content example that is on the market place.
Not only on my project (where I deleted, pawn, controller etc… to tried things)
So there is something wrong somewhere… maybe i should just reinstall all UE4, but I am kinda afraid to do that and broke something you know…
(well it’s already broken in a way…sure) ^
(I didn’t know the comment/answer thingy, thanks !)

Does it still happen if you separate the view?

Still the same thing after a fresh reinstall of everything.
Am I the only one to notice this, or the only one (…) to have that issue… ?
This look like a bad joke.

You know Kris, I don’t know how you reply so fast :slight_smile: but one thing is sure, you are spot on.

It now works in my project perfectly. The thing is I still don’t understand why nobody reported that, because it happens on all unreal content until you create all the BP you mentioned.
I guess nobody care :slight_smile:

…but you, of course !, thank you so much, merci beaucoup for pointing me in the right direction !

I was not planing to make all that Player, camera and controller in my current demo, because it was not needed in my OUDK project.

It’s a kind of cinematic experience. But on UE4 that was needed. This is something to remember !!

I still consider it a bug, or let’s say a “lack or proper implementation by default” (as it was also happening in the VR content map provided by epic.)
Good news, I can turn that page ! :slight_smile:


How do I reply so fast?
Its simple - my phone tells me I need length and thickness (email alert) and I’m already at the keyboard, so…

Glad to hear that you have sorted it.
You should accept this as your answer.
If you feel up to writing a bug report, do that too :slight_smile:

Have a good day sir.


Edit: Wait, this is under bug reports. Ha!

So as far as I can tell, the orientation issue is still there in 4.9.2

this post looks helpful, from the oculus forums.

Could anyone provide a more comprehensive guide on how to achieve the desired initial camera orientation when toggling possession between multiple pawns (blueprint if possible)?
I tried entering a value in “yaw” within the “reset orientation and position” node. That enabled me to start with the camera (VR) facing towards -x, not much, but at least it’s not only +x anymore… :slight_smile:

It could probably be done by “forcing” the player controller to it’s intended position when needed (haven’t tried that yet), but I’d be gret to be able to possess pawns but “inherit” their intended facing.

1 Like