HiResShot AA problems? How to create a decent Still?

Hi. Newbie here. I’m trying to create a decent STILL render and can’t for the life of me figure it out. I know about HiResShot, but it seems to have problems on my Mac. How do others do this?

Here’s what my viewport looks like in the Editor. As you can see, it’s rendered just fine without artifacts. The problem with this are the icons and overlays PLUS you can’t set the render resolution to 2X or 3200x1800.


Now here’s the exact same using both the HiResShot in Play mode as well as the HighResolutonScreenshot tool in Editor mode. You can see the obvious AA artifacting which is unacceptable. Can anyone tell me how they get such wonderful stills? Thanks!


The only decent way I’ve found is by using nvidia dynamic super resolution. (you need a maxwell nvidia gpu, and the dsr option is in the nvidia control panel)

When you use High res shot multiplier to take a bigger screen, it divide the image in tiles and reassemble it to make a final huge image. But while doing so, it cannot save any temporalAA. Huge bummer for arch-viz and product-viz.


Nvidia dynamic super resolution allow you to raise the resolution of your desktop up to 400% of your current resolution, regardless of your monitor size. My native resolution is 2k and when I set DSR to 400% I can reach 5k. It turns my desktop and all my apps in 5k. Now I can press the print screen key on my keyboard and make a 5k screenshot in 1 tile. That means temporalAA and ssr are there!!!

And don’t take screenshots within the editor, just the game in a standalone window in fullscreen, with the viewpoint set to the camera you want to take a ‘‘photo’’ from. Wait couple seconds to let temporalAA settle and hit printscreen!

EDIT : Just saw that you are on mac :-S sorry.

Oculus has released a version of ue4 running with a foward renderer instead of a differed renderer and they use msaa instead of txaa. Maybe it would work better for your high-resolution screenshots.

great tip !

thx Heartlessphil

If you don’t need a higher resolution than what you have in your monitor you can increase the screen percentage value over 100%. You can change it via PPV or camera settings. By default it won’t work in the editor but you can enable it with the console command “r.screenpercentage.Editor 1”.
It’s currently not working in the 4.12 though. I’ve already reported it.

I struggled with this for a while too. I always used the “Shot” command to take the screenshots, but after 4.11 you could no longer set the resolution higher than your monitor. But I finally figured out that you can use the “forceres” commandline to force it!

In a standalone game, use console command “setres 3840x2160 forceres”. Make sure you’re not in fullscreen mode. Then use “Shot” command. This ensures all AA, SSR, and even gameplay programming is working correctly when you’re taking your screenshot. Any resolution you want as long as your graphics card can pump it out.

thx for the tip I’ll try it!

All great ideas. I decided to boot the Mac to the curb and purhased “The New Razer Blade” with a decent nVidia card which should solve some of my problems. The Mac was just crashing too often-- HARD crashes requiring the Mac to reboot. And this was on simple geometry-- can’t imagine what it would do with more difficult models. Not sure why Mac has stuck with ATI even on it’s highest systems.