Hirarchical LOD doesn't hide actors

Hi everybody.
I’m working on the version 4.10.2. We need to use Hierarchical LOD in our maps to reduce Draw Calls number, but I saw that there’s troubles with this tool since version 4.9.

But, it looks like it works… But not completely.
I made a level with a lot of spheres with
I checked the “Enable Hierarchical LOD” option in World Settings, and I’ve created 2 LOD levels for test. After a light Build, I built LODs, and then the Editor create some LOD actors with merged meshes. But, the merged meshes AND the original meshes are both in the level, so they’re clipping and I’ve more draw calls that I can have without HLOD…

Ingame, if I hide the original meshes, I can’t see them when I’m too close, that’s normal. The HLOD loads the first LOD level when I’m at the distance I set in World settings. That’s normal too. But when I go further, when the HLOD loads the second LOD level, the first level is still loaded !

So, when I’m close to an object, I only see the HLOD 0. But, when I’m far enough to load the HLOD 2, all the last levels are shown.

Does someone know how I can make it work well ?

1 Like

Up… The desert of HLOD x)

New up…