High Resolution Shot and Standard Resolution Shot in game not working

If you try to take a Standard Resolution Shot or a High Resolution Shot for a packed product it seems to work (it freeze for a moment) but then it doesn’t create nor the folders, neither the image files in the project folder

How to reproduce the bug:

  • create a new project on 4.14 (I tried with templates and with some projects of mine)
  • add a blueprint Execute Console Command with the command “HighResShot 2” (I’ve used a keyboard “L” event to trigger the console command, and I have inputs enabled)
  • try to play through the editor: both commands work (the “L” event fot the HRS and the F9 for the SRS) and save the screenshots in the saved folder of the project
  • pack the product for Windows 64 (I have Windows 10)
  • lauch the exe: both commands DON’T work (the game freeze for a moment when use the “L” or the F9, but nothing happen on the folder)

I tested too with some (packed) projects I’ve made with 4.11 and everything works as it should

Hello Hainzgrimmer,

I ran the test on Win 7 and Win 10 but was unable to reproduce what you are reporting. I used the ‘L’ key to execute the console command ‘HighResShot 2’ within the level blueprint. Then packaged for Win64 and was able to see the screenshots after pressing the ‘L’ key and following the presented directory.

Could you provide me with either a test project or a way to reproduce this is a new blank project?

If this was already the case, the test project is going to be the way to resolve this discrepancy. Let me know if you have additional questions.

Thank you,

Ok, I’ve remade a FirstPersonShooterTemplate with the console command and I’ve noticed that the High Resolution Shots are indeed taken but they aren’t put in the packed folder but in


I wasn’t able to see the folder destination since my projects are in fullscreen and the little window saying where they were saved was under the game screen; so is a bug that the engine put the shots there instead of the packed-project folder?

anyway the Standard Resolution Shots (taken with F9) aren’t saved in there either.

I’ve saved on my googledrive both the project template I’ve made ( https://drive.google.com/open?id=0B8LeN5hMjH1IUlc0aExPeGNvZDA ) both the project template already packed ( https://drive.google.com/open?id=0B8LeN5hMjH1IX3ZmbjNNZlJ6aEk )

Let me know if you need anything else

Btw I’ve read on this Unreal post on the blog, they use the console command SP.OutputDir F:/StereoCaptureFrames to set a folder for the output of the stereo360: would it be possible to use the same console command to redirect the High Resolution Shots?

So I tested your project (both packaged and editor version) and I am getting the results you are reporting when saving the HighResShot 2 to the directory, but not when I test from a new project in 4.14.

For my test I packaged the project to my desktop and then when saving the screenshot it saved to the proper directory (C:/Users/Me/Desktop/WindowsNoEditor/HRSSTest/Saved/Screenshots/WindowsNoEditor/NameofScreenshot.png.) The ‘Shot’ command no longer is valid as you can use the HighResShot 1 which will take a default screenshot at the current resolution. Not sure how it is grabbing the AppData location, perhaps the directory in which you have it set to package?

For what you are suggesting in regards to writing your own path, it should be as easy as opening up the HRSS tool in code and check to see how/where they are setting the saved shot directory. Then just modify that to whichever file path you would like.

Let me know if you have additional questions.


With the update to the 4.14.1 I tried again to make some test and see if something has changed:

  • if I make a new project (using a FirstPersonShooter as template) now it works correctly and it saves the HighResolutionShots in the folder of the project packed

  • if I try on a project I created directly on 4.14 (it was still the 4.14.0) with a sort of “template” I use for my works, it works correctly

  • if I try on one of my previous works (still made starting from my “template”) but created on a previous version (4.11) and then converted to 4.14, it still saves the HighResolutionShots in C:\Users\user\AppData\Localfolder-with-the-name-of-the-project\Saved\Screenshots\WindowsNoEditor

I always pack all the projects on my E: disk (since the C: is an SSD); good to know that F9 doesn’t work anymore, maybe could be useful to sign it on the documentation page

About setting the path: is there a way to set it through blueprint and not only through code (I’m sorry, I don’t know C++)?

Thanks for the attention

The project you upgraded from a previous version, might have some old or outdated references which is forcing it to save the screenshots to that location. Try deleting your Saved, Intermediate, and Config folders of the converted project to see if that resolves the issue.

I also did some more testing with the F9 key, and although it does not present you with the saved directory prompt while in Standalone, like the HRSS, it will still save the shot to the correct directory i.e YourProject/Saved/Screenshots/Windows. I am going to investigate as to why the prompt does not appear for the standalone window when using the regular (F9) shot command.

In regards to the custom file path, I think that is going to have to be done through code as the HRSST is not a blueprint class but a built in engine tool, therefore it will need to be modified through code.

Let me know if you have further questions.

Thank you,

ok I’ve deleted Saved, Intermediate and Config folders and my project has gone all messed up (I’ve never made such a hard reset before) but I managed to set all the things needed to make it work again: now the HighResolutionShot works properly and save the shots in the packed folder.

Thanks for the help!