Download

High render settings and still not the best quality

Hi

as you can see I’m getting these noise or black dots and in some area tiny white dots although my world settings are high as you can see in the picture and my lighting quality on production and also my wall lightmap res is 2048 and I double-checked that my lightmap compress is unchecked

What else can cause this ?

Hi!

One of your setting is way too high (quality) and one is too low (smoothness)…
BUT
I think it might be your material/normal map… have you tried with just plain grey material?

actually i just figure it out, i’m rendering GPU so i had to adjust in the BaseLightmass file, increace the samples in the last line

[DevOptions.GPULightmass]
NumPrimaryGISamples=32
NumSecondaryGISamples=16
FireflyClampingThreshold=1000.0

i put it

[DevOptions.GPULightmass]
NumPrimaryGISamples=128
NumSecondaryGISamples=32
FireflyClampingThreshold=1000.0

and i’m rendering now once the result came i will post , thank you for your reply

…if you’re using GPU lightmass those World/Lighmass settings are NOT in use!! You can put whatever in those fields, GPU lighmass is automated!!

Oh, so it doesn’t matter what I put in the world setting, how about the lighting quality ?? does it work when using GPU lightmass ?

No! GPULightmass is automated and doesn’t use ANY of those settings!

alright thank you very much i did not know that ! :smiley:

Hi

I made some experiment with the GPU lightmass to see if world settings and lighting quality are effected or not!!

First photo:

world settings:

Static Lighting level Scale: 1
Num Indirect Lighting Bounces: 3
Num Sky Lighting Bounces: 1
Indirect Lighting Quality: 1
Indirect Lighting Smoothness: 1
Lighting Quality: Preview

Time: 2min 19sec

second photo:

Static Lighting level Scale: 0.1
Num Indirect Lighting Bounces: 10
Num Sky Lighting Bounces: 10
Indirect Lighting Quality: 13
Indirect Lighting Smoothness: 1
Lighting Quality: Production

Time: 2min 37sec

as you can see they are affected however in the second test I put the lighting quality to preview to see if that effect or not, it didn’t affect at all but the time reduced from 2min 37 to 2min 20 , but exactly the same result

so only lighting quality is automated, you have to change the world settings

Sry I was wrong!!

Thanks for sharing , i had the same problem using GPU light mass backing and your post helped me a lot , thanks

its okay, so basically other than **Num Indirect Lighting Bounces **is not affected , but how about **Num Sky Lighting Bounces **or **Indirect Lighting Quality **and Indirect Lighting Smoothness ?

because these are related to indirect lighting, i suggest always put setting as you are in CPU lightmass regardless if they are effecting or not