High GPU Usage

I’ve updated my launcher to the last version, but the problem is very high GPU usage and system going very slow and even I can’t move mouse easily!

My Specs:
CPU: Corei7 8700
GPU: Gigabyte 1080ti extreme edition

Are you sure it’s not set to use the Intel GPU?

Launcher support is available at the link - Epic Games Technical Support & Customer Service | Epic Games


Where I can check that?
But I’m sure Intel GPU is not using…

Open the Nvidia Control Panel, under I think 3D settings you can control what apps use which GPU, I just set it to use the Nvidia GPU for everything.

do you mean to set the OpenGL rendering GPU to my vga? I can’t find any other similar options.

By the way, i changed Launcher setting from 3D setting -> Program Settings and now it seems the problem solved.
Power management mode -> Prefer maximum performance
Vertical Sync -> On