Hiding the top bar on OSX Package Builds

Is there any way to make it so that the top bar on OSX will not appear when my game is running? If it’s set to auto hide/show when your mouse gets close, then it seems to always appear, even if my mouse is hidden. I’ve tried various combinations of:

-SetInputModeGame vs SetInputModeGameAndUI
-Setting resolution to fullscreen vs borderless windowed
-Cursor hiding or showing
-Setting the cursor position to the middle of the screen every tick

Every combination I’ve tried, if the player moves their mouse up enough, the top bar drops down over the game, even if there is no visible cursor. Is there any way to disable it completely?

I’m using Unreal 5.3.