Hide touch interface

Hey everyone,

I stuck on 1 problem, i’m trying to make game for iPhone, that means i shell use touch interface, however i don’t wont to see it all the time. I found founction like “Active Touch Interface”, but i have no idea how to hide it.


Project Settings->Input->Always Show Touch Interface

You can also customize it there by sellecting Touch Interface Asset

I can add - Activate Touch Interface
But how to hide it?
I already disable - Show Touch Interface, and call it in bigginer of level/
But, when my character comes to place i want to hide interface, i tryed by activating another inteface,which have nothing, and it’s works, however when i use it, my char still moves after. I mean when level is starting and pressing - Beggin, i’m using - Activate touch interface, when char is coming to finish place i’m still using another activate touch interface, but char is not stoping move, char takes last comand “like move right” and contiuner doing all the time.

Sorry for my english

and when i using “Remove all widgets” it still make the same problem, the char is not stoping

Then setup Default Touch Interface to None or make one that disables controls. It’s kind of fishy for me i think there was option to hide it but it seems it changed with 4.9. Here is docs, read the bottom part:

use Activate Touch Interface Node

1 Like

You can do the following:

  • Go to Edit> Project Settings> Engine Input> Mobile> Default Touch Interface and make it to None
  • In your Blueprint script:
  • When you want to show the touch interface, you can use Activate Touch Interface "YourtouchInterfaceName"
  • When you want to hide the touch interface, you can use Activate Touch Interface "None"
  • Be sure to link the Activate Touch Interface to the correct player Controller by using Get Player Controller and the correct Controller ID