Hide Socket Local Rotation Axis

Testing out UE4 with assets that had been scaled really tiny from a previous game, character is a 1cm tall for reference. I have been scaling assets up in the viewport to compensate and that has worked overall, however when editing in persona or the model viewer I have to zoom way in to see the imported models and generally run into a clipping plane issue with the view camera. My issue, however, is that the local rotation axis is really large and I cannot figure out how to make it smaller. The part that I think is a bug is when I go to the show dropdown menu under the advanced option and set Hierarchy Local Axes to None and it turns off all local axes except for the socket which is the one I would like turned off as it blocks my view for positioning and rotating the character’s weapon. Is there another option to turn it off for sockets?

Hi Jdizzle,

Thank you for your report. I am attempting to reproduce this but I have a few questions. Could you provide a screenshot where you are experiencing the issue? If you set the view in the Skeleton Tree from Active Sockets to Hide All Sockets, does that fix what you are describing?


I am going to mark this post as answered for tracking purposes. You can reopen this issue by posting a new comment with the information requested. When that happens, we will be happy to further investigate.