Download

Hi, how to get source for GitHub

Hi, I am new to unreal.
I am downloading it because I am told that it i possible to add CPP third party plugin or modules to the engine.
I do not see a way to get the code, or the SDK necessary to that.

what I try to clone the reposotroy I get thsi error

an when I try to the site as it is explained in the various page here or on the website I get this message
Untitled1.png

can some one please tell me what I am doing wrong?
Julio

You have to login to github with the account you set in the unreal engine website.

Since you’re using Windows, you can use Github for Windows (https://windows.github.com/) since it’s easier to use your github account (and download the code) from there.

I have Github on Mac, Window and Linux
When I follow the instructions on this place https://www.unrealengine.com/ue4-on-github

the first step take me to this page. but form there nothing else works

Hi Julio,

First you need to go to http://www.unrealengine.com and sign in using the button up top. Once signed in you need to enter your GitHub user name into your account settings and then press save, this will turn on access to the repositories. You should now be able to access the files on GitHub. :slight_smile:

EDIT: This will only work if you have an active subscription to UE4. You can find the settings right here (user name IS case sensitive, make sure it is the exact same):

5c56d36e431171e0995bcd49d51d9a952e1dd01a.png

I already have an unreal account form that link, I already download teh MSi file and test some demos.

the problem is that I can no get the code for GitHub, I contacted Git Hub and the say the problem is that appears that JulioJerez is nor a member of Epic,
But I register last night, and pad the deed. here is the Email from GitHub.

I also contacted Unreal support but I am getting the same kind of respond, basically the link that takes me to a 404 error page.
I also try the same from a different compute that is not in my house, so this is no a internet connection problem

Can you confirm your user name is entered in the field I circled in the above image? You will not be able to access the EpicGames GitHub until you enter your user name into that field.

This is separate from registration, it needs to be done after setting up your account for the first time. Please double check this has been done.

the name I typed lat time was NewtonDynamics and that did not work. That was the name I got what I open the the GitHub Setting, but the people at GitHub
tell me that My user name is JulioJerez so I tryoed that and it did no work either. I also tried JerezJulio, JulioJerez, my Email and nothing worked.

I will try tonight JulioJerez maybe I was wrong the first time.
Thank you

Hopefully that fixes it for you, make sure you use the same case capitalization though, it won’t work if you use all lowercase letters.

If that still doesn’t work then be sure to send an email to accounts@unrealengine.com explaining your situation and providing your account info, they be able to make sure there are no other issues preventing you from getting access.

Hope that helps! :slight_smile:

Ha it worked, I was able to clone it

you can close this thread.
Thank you

Hey guys this really helped they sent an invite after message 4 :slight_smile: im sooooo happy ive been trying to get this for 3 days now thank you very much

Hey guys this really helped they sent an invite after message 4 :slight_smile: im sooooo happy ive been trying to get this for 3 days now thank you very much