Download

Hey ! about the " Move to Location " and " Move to Actor " blueprint nodes !

I’v already left a post in the blueprint forum and no one answered it .

When ever i use these nodes with a navigation mesh, it snap it’s rotation toward the direction and it looks wierd and unnatural .

How do i smooth that rotation toward the new direction the navigation system tells the actor to go to ?

I’v already tried Interpolating it with " Rotation lerp " node but it didn’t help.
I’v tried to store the actor’s rotation before it go through the " Move to Location " in a variable and to lerp form it to the new rotation value that comes after the node, but when i print it to the screen it says that the value of the variable i’v used to store the initial rotation is equal to the value of the current rotation, why ?

Why doesn’t this node has a " smooth rotation factor " option ?

This is the blueprint :

img01.jpg

At work, so can’t test it now - but since Rotator is an instance of class Rotator, perhaps its an issue with copying a reference instead of a value? So you’re just storing another copy of the same Rotator reference, and comparing one to the other. Try actually breaking the rotator into it’s values (floats) and storing/comparing those instead.

Chambered, did you actually manage to make a Pawn walk to a location, without instant rotation when he goes around edges? I experienced the same issues as Sahkan. Also, I’ve yet to see a video of a Pawn turning in a natural way.

See this video for instance:
https://www.youtube.com/watch?v=UpbaCHTcNPA#t=76

Same problem.

No Bajee, I haven’t experimented with it at all yet - I was just pointing out why Sahkan’s BP wasn’t acting like he’s expecting. Even if/when it works, the pawn would still move point-to-point in a straight line, his rotation would just be smoothed out (in other words, it’d still look very broken). Again, I haven’t looked into it - but it seems like the pathfinding logic is quite bare-bones at the moment, for smooth cornering you might have to roll your own.

A couple of Unreal devs in that thread seem to say it can be done like this:

“To fix this, go into the movement component of the character and turn on “Orient Rotation to Movement”, then go into the Defaults of the character and turn off “Use Controller Rotation Yaw”. Let me know if that helps.”

Still the same thing when i’m breaking it to floats too .

OMG man that fixed it now it is smoothed thank you so much ! XD