Here is how to install the UnrealVS plugin with Visual Studio 2019 version 16.1+

This was bugging me, since the plugin is quite helpful and the installer does not work. The reason for this is that it’s fixed to install ONLY to version 16.0, but recently Visual Studio has gone to the 16.1. Fortunately fixing this is easy:

  • go to the plugin’s directory. for instance: C:\Program Files\Epic Games\UE_4.22\Engine\Extras\UnrealVS\VS2019

  • vsix installer files are just zip files. Open the vsix file using 7-zip or some other program.

  • inside the archive open the file “extension.vsixmanifest” for editing

  • change the line “<InstallationTarget Version=“16.0” Id=“Microsoft.VisualStudio.Pro” />” to “<InstallationTarget Version=”[16.0,]" Id=“Microsoft.VisualStudio.Pro” />"

  • repackage the archive, run the vsix installer, and you’re good to go.

All this does it set the minimum version of the installer to 16.0, instead of setting it to ONLY 16.0.

Thank you:D:D:D

@russwb - so I went to the folder here: "C:\Program Files\Epic Games\UE_4.25\Engine\Extras\Unreal\VS\VS2019

Then I renamed the “UnrealVS.vsiz” file to “” (temporarily) so I could open this file using UnZip.

Inside the zipped file, I opened the file “extension.vsixmanifest”

I found the following line:
<InstallationTarget Id=“Microsoft.VisualStudio.Community” Version="[16.0,17.0)" />

Am I supposed to change this line to the following?
<InstallationTarget Id=“Microsoft.VisualStudio.Community” Version="[16.0,17.0]" />

Changing the very last parenthesis to a right bracket? Is that what needs to be done? Or is my version of the vsixmanifest ok to use, and is this just an old bug that is now fixed?

I’m just not sure if I need to change ANYTHING, I would greatly appreciate it, if you could just let me know.


Step 2 of the UE4 "Installation and Setup" instructions (found here) say:

“Run the UnrealVS.vsix file by double-clicking it to begin the installation”

Unfortunately, the “vsix” extension is NOT assigned to any specific program and when I click it, it does nothing.

How do I install this “UnrealVS.vsix” extension? How do I assign that “.vsix” extension to a specific program (Visual Studio 2019 Community?) so that it can run?

The instructions are CLEAR AS MUD in the Unreal Engine 4 Documentation. Hopefully this can be fixed.

Please let me know EXACTLY how to assign the “.vsix” file extension to a specific program (Visual Studio 2019 Community) so that when I “double-click” on that extension/file that it will actually do something. (or at least tell me another way to run this .vsix extension inside of Visual Studio 2019 Community).

Please and thank-you!


For whatever reason, when I tried opening “UnrealVS.vsix” (in 7zip) which didn’t work, it for some reason made windows “default” to using “7zip” for this file extension “vsix” so now whenever I double-click on the “UnrealVS.vsix” file extension, instead of executing and running, it simply tries to open 7-Zip, and throws the following error:

The “VSIX” file extension would NOT open for me (when I double-clicked on it) because it was assigned to 7-Zip (for whatever reason).

I opened Visual Studio 2019 Community, and then clicked on “Extensions” and then clicked on “Manage Extensions” and then at the very bottom it said “Change your settings for Extensions” and I clicked on that. But was unable to find ANY way to install the extension.

After searching on the internet, I found this video here:
So what I did was did a search for “Developer Command Prompt for VS 2019” and then right-clicked and “Run as Administrator”.

Then AFTER I did a search for “Developer Command Prompt for VS 2019” and then right-clicked and “Run as Administrator”.

The next step (at the command prompt) was to type:

cd \Program Files\Epic Games\UE_4.25\Engine\Extras\Unreal\VS\VS2019

Then I executed the following command:

C:\Program Files\Epic Games\UE_4.25\Engine\Extras\UnrealVS\VS2019> **vsixinstaller.exe UnrealVS.vsix **

Then the VSIX Installer window popped up (See image below)

Then I clicked on “Install” and then the “UnrealVS” (VSIX Extension) was properly installed in Visual Studio 2019 Community!

I didn’t have to make ANY of the modifications (listed by @russwb]( in post #1) for installing UnrealVS plugin with Visual Studio 2019 (version 16.6.2) using Unreal Engine 4.25.1

I just followed the step-by-step instructions (that I created/posted above).

I hope this helps, and thank-you to @russwb]( for creating this thread, which I was able to find using Google and doing a search on “How to install UnrealVS extension” and the very first search result took me to this thread, and I read it, and it at least got me thinking (because double clicking on UnrealVS.vsix didn’t work for me) and after findthis YouTube video here), it helped me finally figure out HOW to get the “UnrealVS” plugin installed. (Just follow my detailed instructions above, and that should get it done!)

I hope this helps!

-> Mark

Following my steps above, worked with the very latest Unreal Engine 4.25.1 and Visual Studio Community 2019 (version 16.6.2)

Also, now when I go into Visual Studio Community 2019, and I click on “Extensions” and then “Manage Extensions” and click on “Installed”. It now shows that “UnrealVS” extension is now installed. (See below)

If you follow my step-by-step instructions (listed above) you should be able to get this “UnrealVS” (UnrealVS.vsix) extension installed.

I hope this helps,

-> Mark