Download

Help with variable .ini settings

Hi all this is a follow up post regarding a problem I am still having, I have made a crossbow arrow mod, thanks to feedback through here I have it working and more importantly I have learned…now regarding the arrow mod I have made, I want to add a variable torpor range to the arrow through the gus.ini.

I have used the graph posted up in another thread by pok3r, my direct damage is set to 1, and my torpor set 100, so in theory, all I have to do is set the direct damage through the .ini to 2 and the arrow will do 200 torpor per hit, eda49f419c94f22407f9fd1908cb74dcec768b48.png This is the graph so far.

45052b719ac7b31ea88de86101dbbbf861e6019e.png This is what I would like to know, what values I should be setting in the “SET” nodes so that whatever I write in the gus.ini adjusts the direct damage. thanks

I know exactly what image you got this from. Ont he original, get rid of the “Get bool option ini”, the branch right after and 1 each of make weapon config and set weapon config and it should be what you want.
First of all it looks like you are missing at least one variable. I’ll try to explain what is going to the best of my knowledge which should hopefully answer your questions…
We’ll start at “Get Int Option Ini”. The first “Set” variable is telling it to associate that variable with whatever you named your section. The only thing you should need set for the first setter is “Replicated”
Your connection between the SlowArrow “Getter” and the branch should be an “Equal” Integer with zero as the value. The branch will check the variable settings in the .ini. If it is “Equal” to the .ini setting it will pass through the “True” and on to that setter. That setter should have the default value you want… You need another setter on the false connected to your “Slow Arrow” setter and it will set whatever value is in the .ini to that variable.

this is what I have now, does this look right? the first setter is now replicated, the default values on the setters are “0” I have added the correct section in the gus.ini but it is still not working, I am now starting to understand the process’s but I must admit I’m still a beginner and I’m stumped, I added a equal integer between the “slow arrow” getter and the branch.

also the setter following the true pin on the branch doesn’t seem to make any difference, I can set any number in the setter and it doesn’t change the default torpor.(direct damage)

Also should I have re-parented the blueprint in the blueprint properties to the mods test mode?

You have no damage type set in the make projectile data. That should point to a damage type that deals torpor. Blueprint’/Game/PrimalEarth/CoreBlueprints/DamageTypes/DmgType_ProjectileWithImpactFX_QuadTorp.DmgType_ProjectileWithImpactFX_QuadTorp’ is a good one. Or make your own new dmg type with a custom torpor setting.
The setter connected to the “True” should not have a connection to the getter. Disconnect that and put in the default value (the value to use if they do not specify one).

Basically, the branch is “thinking” like this: Is the .ini blank or have a 0? =
Yes - Sets the value for “SlowArrow” to whatever the value is in the setter right after true.
No - Sets the value for “SlowArrow” to whatever the value is in the .ini
Not having a dmg type is why you saw no difference when changing the value.
Lastly, the devkit only loads the gus at startup so when testing in devkit make sure you restart it.

Not 100% sure what you mean by the last sentence. If you mean set the testgame mode to your custom testgame mode in the primal game data then you only need to do that if you are actually editing the testgame mode blueprint. If you are not making any changes to the game mode then leave it default.
If that is not what you meant please explain.

Ok, after reading your latest reply…I feel pretty dumb, its obvious and logical that the blueprint needs to be linked to the dmg type…as for the last sentence I was grasping at straws, I knew the blueprint had to linked somewhere else, I really need to get my brain working logically again lol thanks for all your help and your patience, I’m gonna go play with the blueprint again…hopefully I wont have to come back and bother you again, thanks Pok3r

back again, as far as I can see it should be working yet, whilst testing in the dev kit and single player no effect to the directdamage, which in turn would change the torpor, is there anywhere I can get hold of an uncooked projectile file that includes a blueprint doing the same thing as I’m trying to do? I don’t want to copy it, but going through a working blueprint I can compare and see where I have gone wrong.

First image is with .ini setting of 200. 2nd image is with no .ini setting so using default. 1 shot each

You will also need to make sure that you are setting the proper projectile dmg to the torpor one you are creating. The example in this picture applies the version of damage based on INI settings.

3eb9cd06574b2708b04bbf9cdd83e41908d5ba5e.png