Help with UE4 Launch Error


I am trying to use the code found in this repository () to create a DLC system for my game. I have got it to a point where it compiles without error in XCode, but I get the following error in UE4.


I have spent the past week trying to fix this error. I can’t seem to debug it because I’m not even sure what it is trying to say. Has anyone seen an error like this before? I could add some code if needed, but I have no idea what part of the code is generating this error.

Any help would be greatly appreciated!!!

-Thank .

That’a actually my repo :smiley: How are you launching it? Is it when you have a packaged build? Or just running the editor after compiling? And what parts of the code do you integrated?

You could also have a look into the saved folder of your project, there should be a log file with more info about the error.

Hey ,

It is your repo, I found it from a link you posted in one of your answers. I’m just running the editor after compiling. I used pretty much all the code you had in the repository. It was exactly what I was looking for so I have to thank you a lot for it!

Unfortunately, I’m a bit of a noob at working with servers. I have the pakfile downloadable at this link. ()

Do I just replace This line

bInitialized = NetPlatform->Initialize(LocalPlatformFile, *FString::Printf(TEXT(""-FileHostIP=%s")"), *ServerHost));

with this line:

bInitialized = NetPlatform->Initialize(LocalPlatformFile, *FString::Printf(TEXT("-=%s"), *ServerHost));

in AssetStreamer.ccp to get that to work?

I will look into the log file and see if I can find anything.


the -FileHostIP is not the url to a file, it’s actually just the IP of your UnrealFileServer. I did the whole proof of concept running that server and never tried it from AWS (I had no account at that moment haha).

What you could try is to host a UnrealFileServer on AWS and see what it does.

Oh ok.

I’ll see if I can look into how to do that. Do you have any hints as to where I am looking?

Thanks, I’ll tell you how it goes.

The UnrealFileServer is a program that comes with any source build, the server is compatible with the engine version is comes with. There is not much documentation but the source is not that hard and the arguments are explained. The basic idea of the file server is to have a UE4 structure hosted online without exposing the files directly, the UnrealFileServer than operates in that same structure serving the files you specify yo your game.

You’re right, there is not very much documentation on UnrealFileServer.

Maybe it would be best if I explained to you exactly what I’m trying to do. I am trying to be able to use the third person template and apply a material I stream from a server to the pawn.

I have went through this post of yours(Stream an asset from the internet - Blueprint - Epic Developer Community Forums) many times, but was never able to do it correctly. So I looked at your repo to see if I could modify it in any way to fit what I wanted.

Now I think all I have left is setting up the server. I’m still struggling with how to approach this though. I got the source build from the github repo, but I’m still not sure how to host UnrealFileServer on AWS or by any other means.

Basically, I’m just trying to demonstrate the repo you posted in action. Any ideas as to how I can do that?

Thanks a lot!

Incase it isn’t obvious, I am very new to this. So your patience is REALLY appreciated!

You could first start the server locally,m just host it in your own machine instead of AWS, just for development ^^.

Could you open a thread in the forum and post the link here? If not the space is getting smaller and smaller here hahaha

sure thing!

I meant on the forums :smiley:

oh haha ok. I was wondering why a new question would leave more room. I made a post, and I’m waiting for approval. If you want you can post an answer for more space.

Ok, once it’s approved post the link please :smiley:

here you go

Nice! see you there then ^^

did anybody try to use AsyncPackageStreamer with 4.15 ?
after calling the mount () i am losing all my files from content folder.