Download

Help with transferring UVs in Maya

I have a model rigged in Maya using A.R.T. I have the same model that I exported via obj and UV’d in another program. I brought the newly UV’d obj model into the same scene as my rigged mesh. The topology was never changed, and I made sure the scale of both models were identical. I selected the UV’d mesh, shift-selected the rigged mesh, Under ‘Mesh’ I selected ‘Transfer Attributes’. Everything is off except for ‘UV sets’ which is set to “All”. And the ‘Sample space’ I set to “Topology”. I’ve tired every combination; Component, Local, World, and UV with little avail. My rigged mesh has old UV’s which I also tried deleting before I ran the Transfer. I even tried the Transfer in both 2014 and 2015 and neither work. I’ve watched a couple of vids of people showing how to transfer UVs, followed them exactly, and still nothing.

Is there something I’m missing, or another solution I can try? Thanks.

If its a rig it may not be transferring to the correct node in the stack. You may be trwnsfering to the group but not the actual skinned geo.

I saw a Youtube vid in which someone did transfer the UVs to a rigged mesh so I know it’s possible.

I know it possible but you have to know what your transferring too. Make sure you have the right geo node selected.

Im new to Maya, how would I choose the different geo nodes?

Post your Maya scene and I’ll take a look at it for you

I just transferred skinning weights to the new UV’d mesh, so thanks for the help anyways.

Tranferring UVs is pretty simple, just for future reference.

Select your UV’d mesh and to Edit UVs > Delete UVs.
Then select your skinned mesh. Goto Mesh > Transfer Attributes and click on the option box.

You want to set the following options:

If everything worked, you should have t

I wish it was that simple. I tried everything, including deleting the UVs like you suggested with little avail. I was able to get it working on meshes that weren’t skinned, but for some reason my skinned mesh with A.R.T wouldn’t work. Thanks though.