Download

Help with Texture Compression Settings

Hello guys.

I am importing a character with materials (diffuse, normal and specular map) from 3dsmax in fbx format to UDK. The problem I realized now is about the texture compression. The textures are in TGA format, and 2048x2048 size.

The problem is that no matter what compression settings I am using, the max in-game resolution of texture (texture browser) is 1024x1024.

I have seen this same problem in UE4, however even changing the LOD group to character did not change max in game resolution, it is still 1024x1024 (while my original tga is 2048 x 2048):

Any help?

it’s not about the compression settings but about the LODgroup settings that are defined in the ini files

check the documentation for more info: here

Thanks man!!! Problem Solved. I changed the max lod size in the ini files and now my textures are rendering in game with fuull resolution!!! Thanks!!!

i want too!!

i looked into,this:
https://docs.unrealengine.com/udk/Th…ommandlet.html

and this:
https://docs.unrealengine.com/udk/Th…p%20Properties

but i wasn´t able to make any changes:(

in the UDK folder are 2 config sub folder,

Engine-Config and UDKGame-Config

the first contains the BaseGame.ini and the BaseSystemSettings.ini where such commandlets appears.

the second contains the DefaultSystemSettings.ini and the UDKSystemSettings.ini,same commandlets appears here as well.

the default is 4096 and yet it´s streamed in 2048.theMaxLODSize is 4096 in each texture group.what do i miss out?!

i intended to go higher than 4196 but when even this is not showing up,than it´s senseless…

the other option would be the “**Num Cinematic Mip Levels” **https://docs.unrealengine.com/udk/Th…roperties.html

this works guess,without the ini.modification but it´s controlled by kismet commands which i was not quiet able to find more infomation…so if somebody knows how to,pls share!

ok,
hope for some solutions,bye.

"

some people can not handle the truth…fine i will figure this with the help of some others.

Did you find [your_game]\Config[your_game]Engine.ini? The setting should be in there. And I believe the maximum texture resolution in UDK is 4096. You can’t go any higher than that.

i´ll look into it next month so i might have more time to check several sources of informations.i will post my result.thx.

No, you can’t go over 4096 in UDK, it is the maximum ammount you can go. But with some good work on the texturing, also with normal maps and specular maps, you can get some cool results, even with low resolutions.

For my game’s maps, for static meshes which make the level geometry i use resolutions of 512x512, only on some important game elements, like vehicles and characters, I use from 1024x1024 until 2048x2048.

About the image sharpenning, UDK uses Mip Maps streaming, which helps with performance, which means, the engine loads a smaller version of the same texture according to distance from camera. However, you can turn off this (I do only for some specific textures, not all, because this makes the game’s textures ugly and kinda pixelated.

Just open the texture on texture viewer, then on MipMap settings select NoMipMaps.

Hello,

for further information,please look into this thread,thanks. https://forums.unrealengine.com/lega…2x8192-texture