Download

Help with Road Content Collision

Hi All,

I have a problem with my collision on my road model.

As below, the collision (shown by the purple lines), are over the top of the sidewalks:

60cae1899c4069125e325fb306ad8b5988b7ee17.jpeg

Resulting in the Character walking over the road as below:

9d88cc8e742cf46f42f8611da1357bbe3585c9dc.jpeg

The Char is following the collision that goes from gutter to gutter across the top of the road.
I have named my custom collision UCX_…_001…

Any help would be appreciated!

Thanks!

Have you enabled “custom collision”?
And if you have anything after the _001 it shouldn’t work.

:slight_smile:

yourmeshname.fbx
UCX_yourmeshname.fbx?

I was unable to gather it from reading your post, but does your road mesh have three separate collision meshes? One for each curb, and a third for the road? If not:

1) Create one cube and re-size it to the length and size of the curb on one side, and change that object’s name to UCX_YourRoadNameHere_00.

2) Make another cube (easier to just duplicate the last sidewalk collision cube you just made and then slide it into place on the opposite end. It should automatically rename itself to UCX_YourRoadNameHere_01; if it doesn’t, then just rename it to that. Now you have the collision set up for your curbs, and lastly you just need to set up one more cube for the collision of your actual road.

3) I see your road is a plane; you’ll want to make your collision for it a cube with thickness, because if anything hits a thin collision object at high velocity, it has a good chance of going right through it and ignoring the collision completely. Create a new cube for your main road collision and resize it to fit the road mesh, and give it a fair amount of thickness (the same thickness as your curbs should be fine). Now name this mesh UCX_YourRoadNameHere_02.

When creating custom collisions, make sure that the first collision object starts with “_00” and not “_01.” Since 00 counts, it will look for that first before any other number. When you import it into Unreal, make sure to uncheck the “Auto Generate Collision” box at the top, or it will override your custom collision and give it a simple collision. Hope that helps!

Do you (in this case) really export 3 seperate ucx?
I join them into one object and export it.
But good to know.

Well maybe I didn’t read the instructions right. https://docs.unrealengine.com/latest/INT/Engine/Content/FBX/StaticMeshes/index.html That link for example, if you scroll down to the lollipop collision, you’ll see that it’s one rectangle hull and one square hull. I took from that that if I wanted a collision that wasn’t specifically a box, I’d need to create a seperate collision mesh to fit each part of the model. Why would it give that example if all I need to do is create one square and extrude a small piece downward to fit the stick part? So the collision still functions properly if there are extrusions done to the single collision mesh?