Download

Help with references

I’m trying to make a mod where items don’t have durability. So all i do is making a copy of both engram and the primalitem of a simple pistol for example, then direct the primalitem to the engram and turn off “can use durability”. When testing it, the pistol still shoots fine and dosen’t lose durability. But i cannot use any attachment on them. I have this problem with every gun that can use attachment really, and only thing i’ve found out is that in reference viewer, the original blueprints have more references on their left side then my copied one, so i assume this is the problem? but i have no idea how to mess around in there since it dosen’t let you add anything to it. i’ve tried just copying a child, remapping the old BP with the new BP in the primaldata, and also just remove the old BP and add the new BP. none of them worked. Also having a problem with the crossbow showing up as a normal bow and cannot use arrows. only then grappling hook, and when that is attached it turns into a crossbow and works normally

really hope i can get help with this because it’s really tiering me out.

Reference1.PNG is the original file
Reference2.PNG is my copied version, seems to miss alot

Ammo and attachments use a"Drag onto Item" array in the item blueprint. You will need to make copies of the attachments and ammos and set them up for your weapons. Take a look at the bow & stone arrow to see how its done.

So i need to make a copy of the BP of every possible reference? I cannot just point my primaldata to the default version of the gun?
This is how it looks. Custom engramentry -> custom primaldata -> default gun. The default attachments are still connected to this default gun.
You mean i need to do it like this? Custom engramentry -> custom primaldata -> custom gun. and also make custom attachments and a custom version of every gun with those attachments attached? I cannot only modify what i need and hope for the game to understand to use the default if i don’t specify anything else? I actually need to make make a custom copy of EVERYTHING that is on the left side of reference1.jpg and manually build the reference viewer from the ground up so reference2.jpg matches?

Also, a new problem occured. the mod works in the ark dev testing area, also locally on my client. but when i try using it on my server, it seems to work halfway. I have remapped the old engramentry and primaldata BP with my new custom ones. when i load the mod on my server and login. the engramentries got replaced correctly, however, the primaldata files didn’t. i can craft the things i modified if they require crafting by hand. but the items crafted in smithy, fabricrated and tek replicator are gone. Do i need to add them under “additional structure engrams”? isn’t it enough just to remap everything? Shouldn’t it just replace the old with the new and every reference to the old file should now point to my new file?

Thanks in advance, i hope i describe my problem clearly.

If you use child instead of copy on the primalitem and weapbp it should work with vanilla ammo but not for attachments

I’ve done some more testing and I got it working to some extent. Problems I now have is that I cannot find any way to connect the attachment to the weapons. I can do like this “engramentry -> primalitem -> weapon BP” and “attachment -> weapon with attachment BP” but it didn’t resolve the problem so am I missing something?

Also. I’ve tried transferring the serversettings I use on my server to my mod, so the mod is in control of what settings the server uses, instead of my game.ini and gameusersettings.ini. Do you know how this is done? I’ve tried putting it all into “testgamemode” BP that is linked to my “primaldata”, however it didn’t work.

Also. Everything else with copying the files of every weapon worked fine, except from the crossbow. When used in-game it shows up as a normal bow that can take normal and trang arrows, but when attaching a grapplinghook to it, it magically transforms into a crossbow, but cannot use the arrows anymore. You know what’s wrong?

Also. I have one gun that I edited the gun BP of (not the primalitem BP). I can build it in game, but I cannot equip it. You know why?

Also. When trying to unlock multiple engrams at once (clicking the yellow engrams to learn everything before it aswell) it dosen’t work for some engrams. Eventhough everything I have modified, i’ve modified the same way.

Thanks in advance!

This is what is causing you issues

I don’t know which issue you are helping with, however i finally found that “drag onto item” seems they were on the primaldata attachments all along…

If you were talking about the issue about my crossbow, this is how its primaldata BP looks like.
You don’t know the answer to my other problems? Do you need more info? Would appreciate if you then said so.

Thanks.