Download

Help with Mixamo autorig, z-up, root motion problem

Hi, after my failed attempt at trying to get my original 3ds max biped rig working for root motion, i have tried using a Mixamo Unreal rig for my mesh but now there is another problem.

It appears unlike the default herotpp skeleton and Kubolds movement animset skeleton, the Mixamo rig is y-up on the root bone so when i apply root motion in UDK this happens.

0065c14b434bc9973bc810b5c25f6c9af286bb85.jpeg

I also work with animations in Motionbuilder, the different axis roots make this rig incompatible with every animation i was going to use, here is the comparison.

10de1979cbdc55b86adfa5054bd720cf2744f3de.jpeg
44d9fb1ed30cee502c382c1842ed69c53a575a06.jpeg

Note i have tried 10’s of different configurations of exporting, importing, retargeting and merging between 3ds max, mixamo, motionbuilder and UDK.
My final option was going to manually reposition the root and ik root bones in 3ds max so that they face the right way, somehow i don’t think that would turn out well.

If someone, anyone could please help me i would be forever grateful. :slight_smile:

did you download the character with the unreal engine setting after autorigging. I don’t know much about character set ups, but I have used fuse characters fine.

I did indeed as it was the only auto-rig they offer with the necessary root bones.

I think I found a solution. Open up FBX Converter, convert the Mixamo file to FBX binary like so.

b033e8d2d1afbb59eee398cdea664d3e2961cbe7.png

Then you want to open it up in Notepad and find the part with the root bone…

531cbde350.png

Change that -90 bit to -180 and reimport!

Thanks for this!! I have been getting around this by importing the Mixamo character as it comes, changing the ‘Root Motion Root Location’ setting in ‘Anim Asset Details’ pane to ‘Anim First Frame’ rather than ‘Ref Pose’. It worked but wasn’t a proper solution.

This is a much better solution.