Download

Help with material

Recently I come back to unreal and I upload an alien model based iin Wayne Barlowe works.
The textures were made in Substance. But the problem is the diffuse in unreal and viewer looks correct but in the material editor looks more shiny. Any help?

Couple things I’m seeing of concern:

  1. The Base Color texture sampler is Linear Color (bottom right of your picture). Base Color textures are Color, be sure to check sRGB in the Texture editor (i.e. double click the texture in your content browser).

  2. Unreal suggests leaving the Specular output alone. You should only use the Roughness, and usually it’s one channel (R, G, or B) and not all three (which is what you have going in your picture)
    You can plug in a 0 into Specular to turn it off and this could get rid of the shininess.

  3. Metallic… same as roughness, one channel. If nothing is metallic you can leave it blank or plug in a 0.

  4. Can’t see you’re normal map so maybe it’s okay idk.

I wrote a page about that, you can find it here How to import Substance Painter textures into UE4 – FPS Game Starter Kit

Still having the same problems. The color base when I check sRGB looks too shiny but when I uncheck looks correct as I show you.
Imgur: The magic of the Internet
This the checked version
Imgur: The magic of the Internet
Mayb this is for a emmisive map?
This is the maps and how change in the material.
Imgur: The magic of the Internet
@SB1985: Maybe it wasnt configured with that. This creature and textures were made in 2018.

You still have the the specular plugged in. You want the green channel of that node to go into roughness.

Specular should be left alone, but this could contribute to the gloss. You can plug a 0 into specular to turn it off and see how that result fairs.

sRGB should be kept on. When it is on, in your material editor, change you Base Color map from Linear Color to Color.