Help with Inventory

Has anyone tried that Tutorial by Ryan Laley? I loved it but I have run into a few issues and it’s even worse since I tried to make it my own thing. I was following the steps all thoroughly, and I thought it’d come together once I test it out, but I honestly do not know where I went wrong here. I warn you guys it’s a doozy, but I do think this is doable.

Here is the Inventory Component:

alt text

Here’s everything I can get so far …; it’s a doozy.

The following are from the Container Blueprint. The idea is that the Container will have an array and you can add as many different items in it as you want.

I later added to the Construction script a way to randomize the array list so that the same items don’t keep reappearing.

But you did not even ask a question or told us what is not working… How can you even expect anyone to deal with this? :slight_smile:

Sorry!!! l got so overwhelmed with trying to figure this out on my own; it really took a toll on me. I’m talking months! I kept on struggling with how to get it to do just one thing, and then I thought don’t be bogged down and work on something else. Before I know it, the issues keep piling up. Plus the time I get on the computer is limited so I’m rushing myself to get something out and done or else I forget and I’m lost; that’s when I really get depressed.

Anyways, my question or main issue is that the items I pick up do not appear in my inventory.

Here’s my goal

I have a menu that automatically pops up when you approach an object. the menu shows a list of items the object contains.
the menu gives three options:

  1. take one item
  2. Take all the items from the list
  3. leave the items and close the menu.

(I realize I might not need a close menu function since the menu disappears automatically when you leave the objet alone.)

The results were:

Menu shows up; I can still control the character but that is fine, since I wanted to navigate the item menu using the Dpad. When I use the dpad up and down buttons the scrollbar only nudges ever so slightly.

the slot structure will appear in the menu even value/ information filled in that slot.

when I press the button to take one item, the items each disappear from the menu but do not appear in my inventory.

the same effect happens when I press the take all items button.

NOTE: I added a print string to read how many items were being added to my players’ inventory array and it remained unchanged. That was when I realized the issue was with the array, but I am not sure where.

and as you’d guessed; it’s because of the way I set it up.

I know it’s because I have too many calls being made to the inventory array but I felt there’d be some different I had to take to get the result I wanted.

Now I just want to see the items appear in the inventory. I need some confirmation that I’m making some progress. Heavy Sigh