Help with importing object into UE4

I am in need to some insight from someone with a little more knowledge. I have been struggling to import this pool table into UE4 for a project that I have been working on. I have little to no experience with blender or any kind of 3d modeling. So, normally i am at the mercy of the objects creator to have everything done properly. Anyway, I have tried importing this into Unreal editor with every possible combination that I am aware of. I have also tried to watch some tutorials on blender and tried correcting some lighting and normals with no luck. The table imports with faces missing but the lighting seems decent already. I was hoping if I attached the object into this post, then someone could hopefully fix the issue or at least tell me what the issue is and how to fix it. Thanks for any replies in advanced!
Edit: I attached an FBX version and OBJ version.…rOqVt2RdLI2DU4…kYl4NlKQOAN3iJ

Could you shade screenshots of what is happening And the blender file instead of the FBX? (remove the materials, save as, all we need is the blank mesh).

Im sorry for my lack of knowledge on this subject. I couldnt figure out how to delete the materials in blender. The place i got my object from didnt have a blender file. I did take some screen shots of what happens when i import the model into ue4 tho. In the picture of the legs it shows one of the legs with complete faces and the other one is see-through. The close up screenshot shows what is happening to the rails of the pool table on import. The zoomed out screenshot shows which rails are affected by this issue (indicated by the blue arrows). Thanks. Wish i could be of more assistance.

offhand it seems like the normals on top are flipped. let me try and see what the file acutally opens like. I’ll update here.

as you can see here, the model is rather poorly made.
Any normal line that’s not pointing upwards is incorrect.

to fix in blender.
Go into Edit mode on the mesh, select all with A, and recalculate normals (Shift N).
normally you get a little popup. tick inside, then untick it just to make sure.

Export and you should be good to go.
Though modeling wise, it’s 424,930 tris, with an INSANE amount of faces on the bottom of it and legs, which you’d probably never be able to see in game… Ideally you should merge all of those together, triangulate and export in FBX to import into unreal.

Thank you so much for the help. I really appreciate it!!

Hello {DOU}The_One](,

I had the same issues in the last couple of days and I want to share with you my latest experience as well as informations from other helpful users here:
As **MostHost LA **mentioned already make sure your normals are actually pointing the right way. To see that, activate the “normal view” as you can see in the picture. Make sure that you are in Edit Mode. If you see bigger lines beside smaller lines, this means that the smaller line is actually pointing inside and not outside. Make sure in Edit Mode everything is selected, then Shift+N or - Mesh->Normals->Recalculate Outside.

If you want to merge all the objects, make sure that the normals are still pointing outside after you merged them. (I had the case that normals were fine and after merging they messed up again. In that case just Shift+N again)

If you still have the issue (like I had) make sure your Scale in Blender is not negative. If its not negative and your normals are fine, you should be good to go!